summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2020-12-30 22:20:46 -0500
committerJason R. Coombs <jaraco@jaraco.com>2020-12-30 22:20:46 -0500
commita36768aa363c8f7b54aae00e11f895ff06337532 (patch)
tree353a2a246fcda804fa1d10905a2084c6a3b9ebc3
parent2b839bad1c2189f4eeb0f74c4a2455ba6687741b (diff)
downloadpytest-runner-a36768aa363c8f7b54aae00e11f895ff06337532.tar.gz
Prefer pytest-enabler to jaraco.test
-rw-r--r--pyproject.toml10
-rw-r--r--setup.cfg3
2 files changed, 5 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 79f088a..b6ebc0b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -7,16 +7,14 @@ skip-string-normalization = true
[tool.setuptools_scm]
-# jaraco/skeleton#22
-[tool.jaraco.pytest.plugins.black]
+[pytest.enabler.black]
addopts = "--black"
-# jaraco/skeleton#22
-[tool.jaraco.pytest.plugins.mypy]
+[pytest.enabler.mypy]
addopts = "--mypy"
-[tool.jaraco.pytest.plugins.flake8]
+[pytest.enabler.flake8]
addopts = "--flake8"
-[tool.jaraco.pytest.plugins.cov]
+[pytest.enabler.cov]
addopts = "--cov"
diff --git a/setup.cfg b/setup.cfg
index 4fc095b..d5010f7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -29,8 +29,7 @@ testing =
pytest-black >= 0.3.7; python_implementation != "PyPy"
pytest-cov
pytest-mypy; python_implementation != "PyPy"
- # jaraco/skeleton#22
- jaraco.test >= 3.2.0
+ pytest-enabler
# local