summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-10-20 16:30:26 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-10-20 16:30:26 -0700
commit8f4e4266cacd6d55abf71d328aeb4b2e64263149 (patch)
treee52306b5bbfa23af0cb78efa4beabdf7517a65d5
parent3560662a7e824bdeb14f2fbb059d5fa953229f29 (diff)
downloadpystache-8f4e4266cacd6d55abf71d328aeb4b2e64263149.tar.gz
Add Python 3.3 support to documentation (but not to the Tox configuration).
-rw-r--r--README.md1
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 4 insertions, 0 deletions
diff --git a/README.md b/README.md
index 4378de4..653da13 100644
--- a/README.md
+++ b/README.md
@@ -46,6 +46,7 @@ Pystache is tested with--
- Python 2.7
- Python 3.1
- Python 3.2
+- Python 3.3
- [PyPy](http://pypy.org/)
[Distribute](http://packages.python.org/distribute/) (the setuptools fork)
diff --git a/setup.py b/setup.py
index 54780e0..f5b417d 100644
--- a/setup.py
+++ b/setup.py
@@ -138,6 +138,7 @@ CLASSIFIERS = (
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.1',
'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: Implementation :: PyPy',
)
diff --git a/tox.ini b/tox.ini
index b5a9394..bef48f2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,6 +3,8 @@
# http://pypi.python.org/pypi/tox
#
[tox]
+# Tox 1.4 drops py24 and adds py33. In the current version, we want to
+# support 2.4, so we can't simultaneously support 3.3.
envlist = py24,py25,py26,py27,py27-yaml,py27-noargs,py31,py32,pypy
[testenv]