summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2012-01-05 17:07:40 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2012-01-05 17:07:40 +0000
commita5ffe7ceeca6a1f4c73d2963fc3e34fe44a2348c (patch)
tree758d51828e3708a8f90e02274c8a28e0c6a5ae40 /README
parent8b8bb7a288a82e7eb44be97286e5057a49df4b28 (diff)
downloadpysendfile-a5ffe7ceeca6a1f4c73d2963fc3e34fe44a2348c.tar.gz
update setup.py and README
Diffstat (limited to 'README')
-rw-r--r--README45
1 files changed, 21 insertions, 24 deletions
diff --git a/README b/README
index 5e2384c..5872d01 100644
--- a/README
+++ b/README
@@ -1,14 +1,13 @@
-=================================
- About
-=================================
+=====
+About
+=====
A python interface to sendfile(2) system call:
http://code.google.com/p/py-sendfile/
-
-=================================
- Install
-=================================
+=======
+Install
+=======
$ sudo setup.py install
@@ -16,23 +15,22 @@ $ sudo setup.py install
$ easy_install py-sendfile
+===================
+Supported platforms
+===================
-=================================
- Supported platforms
-=================================
-
-Linux
-OSX
-FreeBSD
-Dragon Fly BSD
-SunOS
-AIX (non properly tested)
+* Linux
+* OSX
+* FreeBSD
+* Dragon Fly BSD
+* SunOS
+* AIX (non properly tested)
Python versions from 2.5 to 3.3 by using a single code base.
-=================================
- Example usage
-=================================
+=============
+Example usage
+=============
import socket
import errno
@@ -55,10 +53,9 @@ while 1:
break # done
offset += sent
-
-=================================
- Authors
-=================================
+=======
+Authors
+=======
py-sendfile was originally written by Ben Woolley including Linux and FreeBSD
support.