summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Kanakarakis <ivan.kanak@gmail.com>2023-02-14 15:26:30 +0200
committerIvan Kanakarakis <ivan.kanak@gmail.com>2023-02-14 15:46:38 +0200
commite60755e23a4efdbc13e1317128d1dcfa4a9cab9e (patch)
tree9740e7a187829e95a9b46d2c24fc12626467496c
parentbdb58138d92cd4adada209f2f21c04ac62f19a0c (diff)
downloadpysaml2-e60755e23a4efdbc13e1317128d1dcfa4a9cab9e.tar.gz
Release version 7.3.0v7.3.0
Signed-off-by: Ivan Kanakarakis <ivan.kanak@gmail.com>
-rw-r--r--CHANGELOG.md21
-rw-r--r--pyproject.toml2
2 files changed, 19 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e9eb5479..0aa41dbd 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,8 +1,23 @@
# Changelog
-## 7.3.0 (XXXX-XX-XX)
-
-- Support for pymongo >=3.5
+## 7.3.0 (2023-02-14)
+
+- During metadata generation, render extensions both for EntityDescriptor and IdPSSODescriptor
+- Fix compatibility with certain SAML implementation that inflate messasges on the POST binding
+- Update the SWAMID entity category requirements
+- Fix check for NameID when it originates from an encrypted asssertion
+- Add support for pymongo `>=3.5` and `<5`
+- Update README with supported specifications
+- Remove dependency on the six package
+- Cleanup unused imports and pythonisms for Python versions older than 3.6
+- Convert README to markdown
+- Introduce flake8 to check for issues
+- Use black and isort to manage formatting and imports
+- Use poetry to manage the project dependencies, packaging and versions
+- Fix whitespace typos on the eIDAS schemas
+- Try different logout bindings on the saml2.client level
+- Add the mailLocalAddress attribute as part of the saml and shib uri name format bundles
+- Add the isMemberOf attribute as part of the basic attribute format bundle
## 7.2.1 (2022-08-23)
diff --git a/pyproject.toml b/pyproject.toml
index 012c18f0..e7d66b9a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "pysaml2"
-version = "7.3.0-alpha"
+version = "7.3.0"
description = "Python implementation of SAML Version 2 Standard"
license = "Apache-2.0"
authors = ["IdentityPython <discuss@idpy.org>"]