summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorptmcg <ptmcg@9bf210a0-9d2d-494c-87cf-cfb32e7dff7b>2017-03-03 01:10:15 +0000
committerptmcg <ptmcg@9bf210a0-9d2d-494c-87cf-cfb32e7dff7b>2017-03-03 01:10:15 +0000
commit236250b5706bac5ee080b15555abc9f46e473f5b (patch)
tree15d436e938535a29a32ad9b77a39e73c616def49
parent51d6e9584265da40f52bf57ae63cf10f7c660533 (diff)
downloadpyparsing-236250b5706bac5ee080b15555abc9f46e473f5b.tar.gz
Prep for 2.2.0 release
git-svn-id: svn://svn.code.sf.net/p/pyparsing/code/trunk@459 9bf210a0-9d2d-494c-87cf-cfb32e7dff7b
-rw-r--r--src/CHANGES28
-rw-r--r--src/pyparsing.py2
2 files changed, 29 insertions, 1 deletions
diff --git a/src/CHANGES b/src/CHANGES
index d6dee6d..99214c9 100644
--- a/src/CHANGES
+++ b/src/CHANGES
@@ -2,6 +2,34 @@
Change Log
==========
+Version 2.2.0 - March, 2017
+---------------------------
+- Bumped minor version number to reflect compatibility issues with
+ OneOrMore and ZeroOrMore bugfixes in 2.1.10. (2.1.10 fixed a bug
+ that was introduced in 2.1.4, but the fix could break code
+ written against 2.1.4 - 2.1.9.)
+
+- Updated setup.py to address recursive import problems now
+ that pyparsing is part of 'packaging' (used by setuptools).
+ Patch submitted by Joshua Root, much thanks!
+
+- Fixed KeyError issue reported by Yann Bizeul when using packrat
+ parsing in the Graphite time series database, thanks Yann!
+
+- Fixed incorrect usages of '\' in literals, as described in
+ https://docs.python.org/3/whatsnew/3.6.html#deprecated-python-behavior
+ Patch submitted by Ville Skyttä - thanks!
+
+- Minor internal change when using '-' operator, to be compatible
+ with ParserElement.streamline() method.
+
+- New unit test added for dill support for storing pyparsing parsers.
+ Ordinary Python pickle can be used to pickle pyparsing parsers as
+ long as they do not use any parse actions. The 'dill' module is an
+ extension to pickle which *does* support pickling of attached
+ parse actions.
+
+
Version 2.1.10 - October, 2016
-------------------------------
- Fixed bug in reporting named parse results for ZeroOrMore
diff --git a/src/pyparsing.py b/src/pyparsing.py
index d22c683..af5fcd0 100644
--- a/src/pyparsing.py
+++ b/src/pyparsing.py
@@ -61,7 +61,7 @@ The pyparsing module handles some of the problems that are typically vexing when
"""
__version__ = "2.2.0"
-__versionTime__ = "28 Feb 2017 04:37 UTC"
+__versionTime__ = "03 Mar 2017 01:09 UTC"
__author__ = "Paul McGuire <ptmcg@users.sourceforge.net>"
import string