summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini3
1 files changed, 2 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 178cc3e..4a2b679 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,7 +2,7 @@
envlist = {pypy,py26,py27,py33,py34}{,-cryptographyMaster},pypi-readme,check-manifest
[testenv]
-passenv = ARCHFLAGS CFLAGS LC_ALL LDFLAGS
+passenv = ARCHFLAGS CFLAGS LC_ALL LDFLAGS PATH
deps =
setuptools>=7.0 # older setuptools pollute CWD with egg files of dependencies
coverage
@@ -12,6 +12,7 @@ setenv =
# with extra packages.
PYTHONPATH=
commands =
+ openssl version
python -c "import OpenSSL.SSL; print(OpenSSL.SSL.SSLeay_version(OpenSSL.SSL.SSLEAY_VERSION))"
python -c "import cryptography; print(cryptography.__version__)"
coverage run --branch --source=OpenSSL setup.py test