summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorLaurens Van Houtven <_@lvh.cc>2014-06-19 18:07:01 +0200
committerLaurens Van Houtven <_@lvh.cc>2014-06-19 18:07:01 +0200
commitade80a175d231d3f6347364c5a318571ded4d6bd (patch)
treea592141ec9cfcd6dac0e7803628437789c8d3f27 /tox.ini
parent1110bc91457b410d0799285c1f8cb0e7bf43b68b (diff)
downloadpyopenssl-ade80a175d231d3f6347364c5a318571ded4d6bd.tar.gz
Add a meta testenv for metadata: style & packaging
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini18
1 files changed, 17 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 67386d1..39bcf09 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = pypy,py26,py27,py32,py33
+envlist = pypy,py26,py27,py32,py33,meta
[testenv]
setenv =
@@ -8,3 +8,19 @@ setenv =
PYTHONPATH=
# The standard library unittest module can run tests on Python 2.7 and newer
commands = python setup.py test
+
+[testenv:meta]
+deps =
+ pyflakes==0.8.1
+ check-manifest==0.21
+ pip-tools==0.3.4
+ pyroma==1.6
+commands =
+ pyflakes OpenSSL
+ check-manifest
+ pip-review
+ # Work around a bug in pyroma where it returns 1 when it should
+ # return 0, causing tox to believe it failed.
+ # https://bitbucket.org/regebro/pyroma/issue/18
+ sh -c <<EOT {envbindir}/pyroma . || (( $? == 1 )) EOT
+whitelist_externals = sh \ No newline at end of file