summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2022-09-16 08:59:03 -0400
committerGitHub <noreply@github.com>2022-09-16 07:59:03 -0500
commita3483a7ad7415eb6037237b5261fb8a93e863589 (patch)
tree4f26edba68bc7d0f088d4263ef0ce96e29ab1a0a
parenta52db025de436ee457084aebc6f2d9113f69250e (diff)
downloadpyopenssl-a3483a7ad7415eb6037237b5261fb8a93e863589.tar.gz
fixes #1143 -- pin cryptography max version to prevent future pain (#1145)
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b30c159..9faee63 100755
--- a/setup.py
+++ b/setup.py
@@ -96,7 +96,7 @@ if __name__ == "__main__":
package_dir={"": "src"},
install_requires=[
# Fix cryptographyMinimum in tox.ini when changing this!
- "cryptography>=37.0.2",
+ "cryptography>=37.0.2,<39",
],
extras_require={
"test": ["flaky", "pretend", "pytest>=3.0.1"],