summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2021-10-15 08:28:32 -0400
committerGitHub <noreply@github.com>2021-10-15 05:28:32 -0700
commit60a0eef29878433e568a16b16a8c6e42b59cabe3 (patch)
tree164fee644eec42ebd9881dfd837c32c497220a4d
parent7637b1af29e284a99ffb1d6cbe866beee00b2973 (diff)
downloadpyopenssl-60a0eef29878433e568a16b16a8c6e42b59cabe3.tar.gz
Added py310 to support matrix (#1051)
-rw-r--r--.github/workflows/ci.yml3
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
3 files changed, 6 insertions, 2 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index e5e2e6a..231058e 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -14,18 +14,21 @@ jobs:
- {VERSION: "3.7", TOXENV: "py37"}
- {VERSION: "3.8", TOXENV: "py38"}
- {VERSION: "3.9", TOXENV: "py39"}
+ - {VERSION: "3.10", TOXENV: "py310"}
- {VERSION: "pypy3", TOXENV: "pypy3"}
# -cryptographyMain
- {VERSION: "3.6", TOXENV: "py36-cryptographyMain"}
- {VERSION: "3.7", TOXENV: "py37-cryptographyMain"}
- {VERSION: "3.8", TOXENV: "py38-cryptographyMain"}
- {VERSION: "3.9", TOXENV: "py39-cryptographyMain"}
+ - {VERSION: "3.10", TOXENV: "py310-cryptographyMain"}
- {VERSION: "pypy3", TOXENV: "pypy3-cryptographyMain"}
# -cryptographyMinimum
- {VERSION: "3.6", TOXENV: "py36-cryptographyMinimum"}
- {VERSION: "3.7", TOXENV: "py37-cryptographyMinimum"}
- {VERSION: "3.8", TOXENV: "py38-cryptographyMinimum"}
- {VERSION: "3.9", TOXENV: "py39-cryptographyMinimum"}
+ - {VERSION: "3.10", TOXENV: "py310-cryptographyMinimum"}
- {VERSION: "pypy3", TOXENV: "pypy3-cryptographyMinimum"}
# Random order
- {VERSION: "3.9", TOXENV: "py39-randomorder"}
diff --git a/setup.py b/setup.py
index b9cd5bf..85c4569 100755
--- a/setup.py
+++ b/setup.py
@@ -81,13 +81,14 @@ if __name__ == "__main__":
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Security :: Cryptography",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: System :: Networking",
],
- python_requires=(">=3.6"),
+ python_requires=">=3.6",
packages=find_packages(where="src"),
package_dir={"": "src"},
install_requires=[
diff --git a/tox.ini b/tox.ini
index decabbd..110b737 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {pypy,pypy3,py27,py36,py37,py38,py39}{,-cryptographyMain,-cryptographyMinimum}{,-randomorder},py37-twistedTrunk,pypi-readme,check-manifest,flake8,docs,coverage-report
+envlist = {pypy,pypy3,py27,py36,py37,py38,py39,py310}{,-cryptographyMain,-cryptographyMinimum}{,-randomorder},py37-twistedTrunk,pypi-readme,check-manifest,flake8,docs,coverage-report
[testenv]
whitelist_externals =