summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 9 insertions, 29 deletions
diff --git a/setup.py b/setup.py
index 751f082..b3e85a7 100644
--- a/setup.py
+++ b/setup.py
@@ -1,41 +1,21 @@
-# Copyright 2008 Google Inc.
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
-#
-#
-# This is a fork of the pymox library intended to work with Python 3.
-# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
-from distutils.core import setup
+import setuptools
-setup(name='mox3',
- version='0.6.0',
- packages=['mox3', 'mox3.tests'],
- url='https://github.com/openstack-dev/mox3',
- maintainer='OpenStack Developers',
- maintainer_email='openstack-dev@lists.openstack.org',
- license='Apache License, Version 2.0',
- description='Mock object framework for Python 3',
- long_description=('Mox3 is an unofficial port of the of the mox '
- 'framework to Python 3. The library was tested on '
- 'Python version 3.2, 2.7 and 2.6.'),
- classifiers=['Programming Language :: Python',
- 'License :: OSI Approved :: Apache Software License',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Operating System :: OS Independent',
- 'Development Status :: 4 - Beta',
- 'Intended Audience :: Developers',
- 'Topic :: Software Development :: Testing'],
- )
+setuptools.setup(
+ setup_requires=['d2to1>=0.2.10,<0.3', 'pbr>=0.5.10,<0.6'],
+ d2to1=True)