summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrzemyslaw Gajda <quermit@gmail.com>2012-04-26 22:10:26 +0200
committerPrzemyslaw Gajda <quermit@gmail.com>2012-04-26 22:10:26 +0200
commit3075ab868bbeb977c9495ab0a86b4c3e72166d62 (patch)
tree7bbd9cc2ef36cff7d6b0c22adf2d3046d0527eb0
parent0bc03f75efb5d6b4cbe5684326dbe219b1dcf873 (diff)
downloadpymox-3075ab868bbeb977c9495ab0a86b4c3e72166d62.tar.gz
Minor fixes + changes in metadata
-rw-r--r--README1
-rwxr-xr-xmox.py8
-rwxr-xr-xmox_test.py8
-rwxr-xr-xmox_test_helper.py6
-rwxr-xr-xsetup.py10
-rw-r--r--stubout.py6
-rw-r--r--stubout_test.py6
-rw-r--r--stubout_testee.py4
8 files changed, 24 insertions, 25 deletions
diff --git a/README b/README
index a63f79a..7b65393 100644
--- a/README
+++ b/README
@@ -55,4 +55,5 @@ Mox is Copyright 2008 Google Inc, and licensed under the Apache
License, Version 2.0; see the file COPYING for details. If you would
like to help us improve Mox, join the group.
+
This is a modified version from https://github.com/quermit/pymox
diff --git a/mox.py b/mox.py
index 5081dd4..5c62433 100755
--- a/mox.py
+++ b/mox.py
@@ -1,5 +1,3 @@
-#!/usr/bin/python2.4
-#
# Copyright 2008 Google Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -14,9 +12,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# This file was mofified by:
-# quermit@gmail.com
-# dawid.fatyga@gmail.com
+#
+# This is a fork of the pymox library intended to work with Python 3.
+# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
"""Mox, an object-mocking framework for Python.
diff --git a/mox_test.py b/mox_test.py
index 246b5ad..da8591b 100755
--- a/mox_test.py
+++ b/mox_test.py
@@ -1,5 +1,3 @@
-#!/usr/bin/python2.4
-#
# Unit tests for Mox.
#
# Copyright 2008 Google Inc.
@@ -16,9 +14,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# This file was mofified by:
-# quermit@gmail.com
-# dawid.fatyga@gmail.com
+#
+# This is a fork of the pymox library intended to work with Python 3.
+# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
import io
import unittest
diff --git a/mox_test_helper.py b/mox_test_helper.py
index 21c3baf..339a70b 100755
--- a/mox_test_helper.py
+++ b/mox_test_helper.py
@@ -1,5 +1,3 @@
-#!/usr/bin/python2.4
-#
# Copyright 2008 Google Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -14,7 +12,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# This file was mofified by quermit@gmail.com
+#
+# This is a fork of the pymox library intended to work with Python 3.
+# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
"""A very basic test class derived from mox.MoxTestBase, used by mox_test.py.
diff --git a/setup.py b/setup.py
index 9b6f95c..7169983 100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,3 @@
-#!/usr/bin/python2.4
-#
# Copyright 2008 Google Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -14,18 +12,20 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# This file was mofified by quermit@gmail.com
+#
+# This is a fork of the pymox library intended to work with Python 3.
+# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
from distutils.core import setup
setup(name='mox',
- version='0.5.3',
+ version='0.5.4',
py_modules=['mox', 'stubout'],
url='https://github.com/quermit/pymox',
maintainer='quermit',
maintainer_email='quermit@gmail.com',
license='Apache License, Version 2.0',
description='Mock object framework',
- long_description=('Mox is a mock object framework for Python based on'
+ long_description=('Mox is a mock object framework for Python based on '
'the Java mock object framework EasyMock.'),
)
diff --git a/stubout.py b/stubout.py
index c749396..f956c3b 100644
--- a/stubout.py
+++ b/stubout.py
@@ -1,5 +1,3 @@
-#!/usr/bin/python2.4
-#
# Copyright 2008 Google Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -14,7 +12,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# This file was mofified by quermit@gmail.com
+#
+# This is a fork of the pymox library intended to work with Python 3.
+# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
import inspect
diff --git a/stubout_test.py b/stubout_test.py
index 6f0935e..916d4ad 100644
--- a/stubout_test.py
+++ b/stubout_test.py
@@ -1,5 +1,3 @@
-#!/usr/bin/python2.4
-#
# Unit tests for stubout.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -14,7 +12,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# This file was mofified by quermit@gmail.com
+#
+# This is a fork of the pymox library intended to work with Python 3.
+# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
import unittest
diff --git a/stubout_testee.py b/stubout_testee.py
index 57c409c..24e15ef 100644
--- a/stubout_testee.py
+++ b/stubout_testee.py
@@ -12,7 +12,9 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# This file was mofified by quermit@gmail.com
+#
+# This is a fork of the pymox library intended to work with Python 3.
+# The file was modified by quermit@gmail.com and dawid.fatyga@gmail.com
def SampleFunction():