summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Anderson <sontek@gmail.com>2015-07-16 13:38:04 -0700
committerJohn Anderson <sontek@gmail.com>2015-07-16 13:38:04 -0700
commit917167aaa7e7e4e315f1120720ab273ac155471b (patch)
tree118becc9dcc5a43ae3a7cea9ce79c7497cebb3dc
parentfe534294e11ad7f66bf8057d67a94835bd7667b9 (diff)
parent3444e0e9d19f3a2426c90da0e695dac8f0faa518 (diff)
downloadpymemcache-917167aaa7e7e4e315f1120720ab273ac155471b.tar.gz
Merge branch 'master' of github.com:pinterest/pymemcache into add_hashing_client
Conflicts: setup.py
-rw-r--r--ChangeLog.rst6
-rw-r--r--MANIFEST.in2
-rw-r--r--README.md2
-rw-r--r--setup.py10
4 files changed, 17 insertions, 3 deletions
diff --git a/ChangeLog.rst b/ChangeLog.rst
new file mode 100644
index 0000000..8900aa8
--- /dev/null
+++ b/ChangeLog.rst
@@ -0,0 +1,6 @@
+Change Log
+==========
+New in version 1.2.9
+--------------------
+
+* Introduced PooledClient a thread-safe pool of clients
diff --git a/MANIFEST.in b/MANIFEST.in
index 0bad4fb..a82c813 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,4 +1,4 @@
-include README.* setup.py setup.cfg LICENSE.txt
+include README.* ChangeLog.* setup.py setup.cfg LICENSE.txt
recursive-include pymemcache *.py
global-exclude *.pyc
global-exclude *.pyo
diff --git a/README.md b/README.md
index 0f5ce70..b383b23 100644
--- a/README.md
+++ b/README.md
@@ -72,7 +72,7 @@ The memcached text protocol reference page:
https://github.com/memcached/memcached/blob/master/doc/protocol.txt
The python-memcached library (another pure-Python library):
- http://www.tummy.com/Community/software/python-memcached/
+ https://github.com/linsomniac/python-memcached
Mixpanel's Blog post about their memcached client for Python:
http://code.mixpanel.com/2012/07/16/we-went-down-so-we-wrote-a-better-pure-python-memcache-client/
diff --git a/setup.py b/setup.py
index 9183a9d..55eb27b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,9 +1,17 @@
#!/usr/bin/env python
+import os
from setuptools import setup, find_packages
from pymemcache import __version__
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+readme = read('README.md')
+changelog = read('ChangeLog.rst')
+
+
setup(
name='pymemcache',
version=__version__,
@@ -12,7 +20,7 @@ setup(
packages=find_packages(),
install_requires=['six'],
description='A comprehensive, fast, pure Python memcached client',
- long_description=open('README.md').read(),
+ long_description=readme + '\n' + changelog,
license='Apache License 2.0',
url='https://github.com/Pinterest/pymemcache',
classifiers=[