summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Gordon <jogo@users.noreply.github.com>2018-09-14 13:22:08 -0700
committerGitHub <noreply@github.com>2018-09-14 13:22:08 -0700
commit9dc6eb9cbe0e9a941fc6b2c7e4548540dde4e062 (patch)
tree4a9422ff9d198a87e6d3259fb463b5d68d558ee1
parentf6ecb29e997e377246149271afc5300ea21bac60 (diff)
parentd2c719f8918ee1da38151178ec78b203ee9a0507 (diff)
downloadpymemcache-2.0.0.tar.gz
Merge pull request #189 from jogo/2.0v2.0.0
Prepare for release of 2.0.0
-rw-r--r--ChangeLog.rst21
-rw-r--r--pymemcache/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py1
4 files changed, 17 insertions, 9 deletions
diff --git a/ChangeLog.rst b/ChangeLog.rst
index e756045..9bb4108 100644
--- a/ChangeLog.rst
+++ b/ChangeLog.rst
@@ -1,8 +1,14 @@
Change Log
==========
-New in draft
+New in version 2.0.0
--------------------
-* Change set_many and set_multi api return value. see [pr](https://github.com/pinterest/pymemcache/pull/179)
+* Change set_many and set_multi api return value. `PR#179 <https://github.com/pinterest/pymemcache/pull/179>`_
+* Fix support for newbytes from python-future. `PR#187 <https://github.com/pinterest/pymemcache/pull/187>`_
+* Add support for Python 3.7, and drop support for Python 3.3
+* Properly batch Client.set_many() call. `PR#182 <https://github.com/pinterest/pymemcache/pull/182>`_
+* Improve _check_key() and _store_cmd() performance. `PR#183 <https://github.com/pinterest/pymemcache/pull/183>`_
+* Properly batch Client.delete_many() call. `PR#184 <https://github.com/pinterest/pymemcache/pull/184>`_
+* Add option to explicitly set pickle version used by serde. `PR#190 <https://github.com/pinterest/pymemcache/pull/190>`_
New in version 1.4.4
--------------------
@@ -10,20 +16,24 @@ New in version 1.4.4
* full benchmarks in test
* fix flake8 issues
* Have mockmemcacheclient support non-ascii strings
+* Switch from using pickle format 0 to the highest available version. See `PR#156 <https://github.com/pinterest/pymemcache/pull/156>`_
+
+ *Warning*: different versions of python have different highest pickle versions: https://docs.python.org/3/library/pickle.html
+
New in version 1.4.3
--------------------
* Documentation improvements
-* Fixed cachedump stats command, see [ticket](https://github.com/pinterest/pymemcache/issues/103)
+* Fixed cachedump stats command, see `ticket <https://github.com/pinterest/pymemcache/issues/103>`_
* Honor default_value in HashClient
New in version 1.4.2
--------------------
-* Drop support for python 2.6, see [ticket](https://github.com/pinterest/pymemcache/issues/139)
+* Drop support for python 2.6, see `ticket <https://github.com/pinterest/pymemcache/issues/139>`_
New in version 1.4.1
--------------------
-* Python 3 serializations [fixes](https://github.com/pinterest/pymemcache/pull/131)
+* Python 3 serializations `fixes <https://github.com/pinterest/pymemcache/pull/131>`_
* Drop support for pypy3
* Comment cleanup
* Add gets_many to hash_client
@@ -82,4 +92,3 @@ New in version 1.3.0
New in version 1.2.9
--------------------
* Introduced PooledClient a thread-safe pool of clients
-
diff --git a/pymemcache/__init__.py b/pymemcache/__init__.py
index 1d1cde0..77fbd70 100644
--- a/pymemcache/__init__.py
+++ b/pymemcache/__init__.py
@@ -1,2 +1,2 @@
-__version__ = '1.4.4'
+__version__ = '2.0.0'
__author__ = "Charles Gordon"
diff --git a/setup.cfg b/setup.cfg
index 823b446..45c6bc9 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 1.4.4
+current_version = 2.0.0
commit = False
tag = True
diff --git a/setup.py b/setup.py
index c95bc15..7984cc9 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,6 @@ setup(
classifiers=[
'Programming Language :: Python',
'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',