summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 11 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e4b0ae8..5352833 100644
--- a/setup.py
+++ b/setup.py
@@ -52,7 +52,7 @@ sys.modules.pop('__pkginfo__', None)
__pkginfo__ = __import__("__pkginfo__")
# import required features
from __pkginfo__ import modname, version, license, description, \
- web, author, author_email
+ web, author, author_email, classifiers
distname = getattr(__pkginfo__, 'distname', modname)
scripts = getattr(__pkginfo__, 'scripts', [])
@@ -131,7 +131,15 @@ class MyInstallLib(install_lib.install_lib):
else:
exclude = set()
shutil.rmtree(dest, ignore_errors=True)
- shutil.copytree(directory, dest, ignore=lambda dir, names: list(set(names) & exclude))
+ shutil.copytree(directory, dest)
+ # since python2.5's copytree doesn't support the ignore
+ # parameter, the following loop to remove the exclude set
+ # was added
+ for (dirpath, dirnames, filenames) in os.walk(dest):
+ for n in filenames:
+ if n in exclude:
+ os.remove(os.path.join(dirpath, n))
+
if sys.version_info >= (3, 0):
# process manually python file in include_dirs (test data)
@@ -179,6 +187,7 @@ def install(**kwargs):
author_email=author_email,
url=web,
scripts=ensure_scripts(scripts),
+ classifiers=classifiers,
data_files=data_files,
ext_modules=ext_modules,
cmdclass={'install_lib': MyInstallLib,