summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--DEPENDS2
-rw-r--r--README2
-rw-r--r--__pkginfo__.py2
-rw-r--r--debian.sid/control4
-rw-r--r--debian/control2
5 files changed, 6 insertions, 6 deletions
diff --git a/DEPENDS b/DEPENDS
index acbe171..630cec8 100644
--- a/DEPENDS
+++ b/DEPENDS
@@ -1,3 +1,3 @@
python-logilab-common (>= 0.19.0)
-python-logilab-astng (>= 0.16.1)
+python-astroid
python-tk
diff --git a/README b/README
index 2d8248e..d6d9537 100644
--- a/README
+++ b/README
@@ -21,7 +21,7 @@ or read the archives at http://lists.python.org/pipermail/code-quality/
Install
-------
-Pylint requires the astroid (the later the better; used to be called
+Pylint requires the astroid (the later the better; formerly known as
logilab-astng) and logilab-common (version >= 0.53) packages.
* https://bitbucket.org/logilab/astroid
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 3980541..d4fbf59 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -21,7 +21,7 @@ modname = distname = 'pylint'
numversion = (0, 28, 0)
version = '.'.join([str(num) for num in numversion])
-install_requires = ['logilab-common >= 0.53.0', 'logilab-astroid >= 0.24.3']
+install_requires = ['logilab-common >= 0.53.0', 'astroid >= 0.24.3']
license = 'GPL'
description = "python code static checker"
diff --git a/debian.sid/control b/debian.sid/control
index 8941f09..f062531 100644
--- a/debian.sid/control
+++ b/debian.sid/control
@@ -12,7 +12,7 @@ Vcs-Browser: http://hg.logilab.org/pylint
Package: pylint
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53), python-logilab-astng (>= 0.21)
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53), python-astroid
Recommends: python-tk
XB-Python-Version: ${python:Versions}
Description: python code static checker and UML diagram generator
@@ -37,7 +37,7 @@ Description: python code static checker and UML diagram generator
Package: pylint3
Architecture: all
-Depends: ${python3:Depends}, ${misc:Depends}, python3-logilab-common (>= 0.53), python3-logilab-astng (>= 0.21)
+Depends: ${python3:Depends}, ${misc:Depends}, python3-logilab-common (>= 0.53), python3-astroid
Recommends: python3-tk
XB-Python-Version: ${python3:Versions}
Description: python code static checker and UML diagram generator
diff --git a/debian/control b/debian/control
index 8c43545..d33f620 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,7 @@ Vcs-Browser: http://svn.debian.org/viewsvn/python-apps/packages/pylint/trunk/
Package: pylint
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53.0), python-logilab-astng (>= 0.24.3)
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.53.0), python-astroid
Suggests: python-tk
XB-Python-Version: ${python:Versions}
Conflicts: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test