summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorSandro Tosi <sandro.tosi@gmail.com>2015-03-01 12:49:09 +0000
committerSandro Tosi <sandro.tosi@gmail.com>2015-03-01 12:49:09 +0000
commitdf5ac91fd7c365231c850353f83e5abe6f0969d3 (patch)
treee8786cb0286f0b3afebe856d2ebd06eb015db9bb /doc
parente6ae438fd29d54ec6aca84f750c55b58da998151 (diff)
downloadpylint-df5ac91fd7c365231c850353f83e5abe6f0969d3.tar.gz
Make the doc buildable using the current checkout
Passing the PYTHONPATH from the command line, and setting PATH to the built script, this change will make it possible to use the built code used instead of the system-wide installation to build the documentation. Usage example: PATH=./build/scripts-2.7:$PATH make -C doc html PYTHONPATH=./build/lib
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/doc/Makefile b/doc/Makefile
index d483f63..2cd7f7e 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -6,6 +6,7 @@ SPHINXOPTS =
SPHINXBUILD = sphinx-build
PAPER =
BUILDDIR = _build
+PYTHONPATH =
# Internal variables.
PAPEROPT_a4 = -D latex_paper_size=a4
@@ -138,7 +139,7 @@ features:
echo "" >> features.rst
echo ".. generated by pylint --full-documentation" >> features.rst
echo "" >> features.rst
- pylint --full-documentation >> features.rst
+ PYTHONPATH=$(PYTHONPATH) pylint --full-documentation >> features.rst
gen-examples:
chmod u+w ../examples/pylintrc