summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2014-10-15 14:30:13 +0300
committerClaudiu Popa <pcmanticore@gmail.com>2014-10-15 14:30:13 +0300
commit69672965cabf5f31d3f17c2095ba9685deafb0a8 (patch)
tree91bdd0b52e3fe032520f910ecc04b2184f2f7eed /doc
parenta20b20729bad9edfb9a97cb618f742d9a76266a5 (diff)
downloadpylint-69672965cabf5f31d3f17c2095ba9685deafb0a8.tar.gz
Add new '-j' option for running checks in sub-processes.
Patch by Michal Nowikowski.
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile2
-rw-r--r--doc/run.rst27
2 files changed, 25 insertions, 4 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 98076a6..d483f63 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -12,7 +12,7 @@ PAPEROPT_a4 = -D latex_paper_size=a4
PAPEROPT_letter = -D latex_paper_size=letter
ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
-.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest
+.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest all
help:
@echo "Please use \`make <target>' where <target> is one of"
diff --git a/doc/run.rst b/doc/run.rst
index d4a2aa9..f8a65e2 100644
--- a/doc/run.rst
+++ b/doc/run.rst
@@ -90,7 +90,7 @@ expression in special cases). For a full list of options, use ``--help``
Specifying all the options suitable for your setup and coding
standards can be tedious, so it is possible to use a configuration file to
-specify the default values. You can specify a configuration file on the
+specify the default values. You can specify a configuration file on the
command line using the ``--rcfile`` option. Otherwise, Pylint searches for a
configuration file in the following order and uses the first one it finds:
@@ -117,7 +117,7 @@ includes:
* Options appearing before ``--generate-rcfile`` on the Pylint command line
Of course you can also start with the default values and hand tune the
-configuration.
+configuration.
Other useful global options include:
@@ -128,5 +128,26 @@ Other useful global options include:
--output-format=<format> Select output format (text, html, custom).
--msg-template=<template> Modifiy text output message template.
--list-msgs Generate pylint's messages.
---full-documentation Generate pylint's full documentation, in reST
+--full-documentation Generate pylint's full documentation, in reST
format.
+
+Parallel execution
+------------------
+
+It is possible to speed up the execution of Pylint. If the running computer has more CPUs than one
+then the files to be checked could be spread on all processors to Pylint sub-processes.
+This functionality is exposed via ``-j`` command line parameter. It takes a number of sub-processes
+that should be spawned. If provided number is 0 then the number of CPUs will be taken.
+Default number is 1.
+
+Example::
+
+ pylint -j 4 mymodule1.py mymodule2.py mymodule3.py mymodule4.py
+
+This will spawn 4 parallel Pylint sub-process. Each provided module will be checked in parallel.
+Discovered problems by checkers are not displayed immediatelly. They are shown just after completing
+checking a module.
+
+There are some limitations in running checks in parallel in current implementation.
+It is not possible to use custom plugins (i.e. ``--load-plugins`` option).
+It is also not possible to use initialization hook (i.e. ``--init-hook`` option).