summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAlexandre Fayolle <alexandre.fayolle@logilab.fr>2009-07-02 10:05:59 +0200
committerAlexandre Fayolle <alexandre.fayolle@logilab.fr>2009-07-02 10:05:59 +0200
commit3d97c36353fcc9cbc4e769b14c3a495f2843c01e (patch)
tree904b5dee645a78386321a2b74e89ea052a711715 /debian
parente48dd359d591deb0c071e499664d8a8354dac930 (diff)
downloadpylint-3d97c36353fcc9cbc4e769b14c3a495f2843c01e.tar.gz
backported Debian packaging stuff from Debian
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control4
-rw-r--r--debian/copyright37
-rw-r--r--debian/pylint.dirs1
-rwxr-xr-xdebian/rules10
5 files changed, 39 insertions, 22 deletions
diff --git a/debian/changelog b/debian/changelog
index 731c801..335524e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+pylint (0.18.0-2) UNRELEASED; urgency=low
+
+ * Python transition, thanks Alessio Treglia for the patch (Closes: #530509)
+ - Use --install-layout=deb for setup.py install.
+ - Replace site-packages by *-packages.
+ - Build-depends on python >= 2.5.4-1~ for --install-layout=deb.
+
+ -- Julien Lavergne <julien.lavergne@gmail.com> Sun, 31 May 2009 01:24:53 +0200
+
pylint (0.18.0-1) unstable; urgency=low
* change to python-support
diff --git a/debian/control b/debian/control
index 20ac5a7..a8c351e 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: python
Priority: optional
Maintainer: Python Applications Packaging Team <python-apps-team@lists.alioth.debian.org>
Uploaders: Sylvain Thénault <sylvain.thenault@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>, Sandro Tosi <morph@debian.org>
-Build-Depends: debhelper (>= 5.0.38), python
+Build-Depends: debhelper (>= 5.0.38), python (>= 2.4)
Build-Depends-Indep: python-support
Standards-Version: 3.8.1
XS-Python-Version: all
@@ -13,7 +13,7 @@ Vcs-Browser: http://svn.debian.org/viewsvn/python-apps/packages/pylint/trunk/
Package: pylint
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.35.0), python-logilab-astng (>= 0.19.0)
+Depends: ${python:Depends}, ${misc:Depends}, python-logilab-common (>= 0.39.0), python-logilab-astng (>= 0.19.0)
Recommends: python-tk
XB-Python-Version: ${python:Versions}
Conflicts: python2.2-pylint, python2.3-pylint, python2.4-pylint, pylint-common, pylint-test
diff --git a/debian/copyright b/debian/copyright
index e574a13..c2c1d7d 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -4,26 +4,31 @@ It was downloaded from ftp://ftp.logilab.org/pub/pylint
Upstream Author:
- Sylvain Thenault <sylvain.thenault@logilab.fr>
+ Sylvain Thenault <sylvain.thenault@logilab.fr>
Copyright:
-Copyright (c) 2003-2006 Sylvain Thenault (thenault@gmail.com).
-Copyright (c) 2003-2006 LOGILAB S.A. (Paris, FRANCE).
-http://www.logilab.fr/ -- mailto:contact@logilab.fr
+ Copyright (c) 2003-2009 Sylvain Thenault (thenault@gmail.com).
+ Copyright (c) 2003-2009 LOGILAB S.A. (Paris, FRANCE).
+ http://www.logilab.fr/ -- mailto:contact@logilab.fr
-This program is free software; you can redistribute it and/or modify it under
-the terms of the GNU General Public License as published by the Free Software
-Foundation; either version 2 of the License, or (at your option) any later
-version.
+License:
-This program is distributed in the hope that it will be useful, but WITHOUT
-ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+ This program is free software; you can redistribute it and/or modify it under
+ the terms of the GNU General Public License as published by the Free Software
+ Foundation; either version 2 of the License, or (at your option) any later
+ version.
-You should have received a copy of the GNU General Public License along with
-this program; if not, write to the Free Software Foundation, Inc.,
-51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+ This program is distributed in the hope that it will be useful, but WITHOUT
+ ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
-On Debian systems, the complete text of the GNU General Public License
-may be found in '/usr/share/common-licenses/GPL'.
+ You should have received a copy of the GNU General Public License along with
+ this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+On Debian systems, the complete text of the GNU General Public License v2
+may be found in '/usr/share/common-licenses/GPL-2'.
+
+The Debian packaging is Copyright (C) 2008-2009, Sandro Tosi <morph@debian.org>
+and is licensed under the same terms as upstream code (see above).
diff --git a/debian/pylint.dirs b/debian/pylint.dirs
index 6a39af5..9697bac 100644
--- a/debian/pylint.dirs
+++ b/debian/pylint.dirs
@@ -1,2 +1 @@
-usr/share/doc/pylint/test
usr/share/emacs/site-lisp/pylint
diff --git a/debian/rules b/debian/rules
index b1d09f9..725d29e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,7 +25,9 @@ clean:
find . -name "*.pyc" -delete
- dh_clean build-stamp build
+ rm -rf build
+
+ dh_clean build-stamp
install: build
dh_testdir
@@ -33,9 +35,11 @@ install: build
dh_clean -k
dh_installdirs
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/pylint/usr/
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ --root=$(CURDIR)/debian/pylint \
+ --install-layout=deb
- rm -rf debian/pylint/usr/lib/python*/site-packages/pylint/test
+ rm -rf debian/pylint/usr/lib/python*/*-packages/pylint/test
# fixes shebangs
for exec in pylint pylint-gui symilar ; do \