summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-09-22 05:55:23 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-09-22 05:55:23 +0200
commit3d7f92cbfbdb9fb4c1dd5f479cd4ba04bdeb4f25 (patch)
tree87a72ddb291282370b5cbabc2a4c1e73b8f1e9dc /appveyor.yml
parentf01bff14710891ad28f351c608aa6a316eeb2372 (diff)
downloadpylint-3d7f92cbfbdb9fb4c1dd5f479cd4ba04bdeb4f25.tar.gz
Added support for AppVeroy for CI on Windowswin-ci-5
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml44
1 files changed, 44 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 0000000..7613e62
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,44 @@
+environment:
+ matrix:
+ - PYTHON: "C:\\Python27"
+ TOXENV: "py27"
+
+ - PYTHON: "C:\\Python33"
+ TOXENV: "py33"
+
+ - PYTHON: "C:\\Python34"
+ TOXENV: "py34"
+
+install:
+ - ECHO "Filesystem root:"
+ - ps: "ls \"C:/\""
+
+ # Install pip when not already installed.
+ - "powershell ./appveyor/install.ps1"
+
+ # Prepend newly installed Python to the PATH of this build (this cannot be
+ # done from inside the powershell script as it would require to restart
+ # the parent CMD process).
+ - "SET PATH=%PYTHON%;%PYTHON%\\Scripts;%PATH%"
+
+ # Check that we have the expected version and architecture for Python
+ - "python --version"
+ - "python -c \"import struct; print(struct.calcsize('P') * 8)\""
+
+ # Install the build dependencies of the project.
+ - "pip install tox==1.7.2"
+ - "pip install wheel"
+
+build: false
+
+test_script:
+ - "tox"
+
+after_test:
+ # If tests are successful, create a whl package for the project.
+ - "python setup.py bdist_wheel bdist_wininst"
+ - ps: "ls dist"
+
+artifacts:
+ # Archive the generated wheel package in the ci.appveyor.com build report.
+ - path: dist\*