summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:12:12 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 12:12:12 +0200
commit7bc59b752bf555d3bdf0245f9fcd2cfcc4e7ec60 (patch)
treeb3b400f4576f6ae23601b9302b0ff6c943d4e6a4 /Makefile
parent965366e716cdc247a9918df8c542857342fe9827 (diff)
downloadpylint-7bc59b752bf555d3bdf0245f9fcd2cfcc4e7ec60.tar.gz
Another fix for generating docs from Makefile - added install sphinx.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 83fb5b8..cf6627d 100644
--- a/Makefile
+++ b/Makefile
@@ -28,10 +28,9 @@ tests: $(TOX)
$(TOX) $(toxparams)
docs: $(PIP)
- rm -f /tmp/pylint
- ln -s -f $(CURDIR) /tmp/pylint
$(PIP) install .
- PYTHONPATH=/tmp PATH=$(CURDIR)/pyve/bin:$(PATH) make all -C doc
+ $(PIP) install Sphinx
+ . pyve/bin/activate; make all -C doc
deb:
debuild -b -us -uc
@@ -43,7 +42,6 @@ lint: $(PIP)
clean:
rm -rf $(PYVE)
rm -rf .tox
- rm -rf /tmp/pylint1 /tmp/pylint2
make clean -C doc
debuild clean