summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 14:02:15 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 14:02:15 +0200
commit41b8a34e6282cb7898f4af0bbc6a4da2a12724d3 (patch)
tree409b0d4e49786819482295d3d19d763d546c36d3 /Makefile
parent7764f10a8b64e5f241af609c393c1f1b5e65f240 (diff)
downloadpylint-41b8a34e6282cb7898f4af0bbc6a4da2a12724d3.tar.gz
Updated help and added clobber target to Makefile.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 0859f35..c0027c2 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,8 @@ help:
@echo "Please use \`make <target>' where <target> is one of"
@echo " tests to run whole test suit of PyLint"
@echo " docs to generate all docs including man pages and exemplary pylintrc"
- @echo " deb to build debian package"
+ @echo " deb to build debian .deb package"
+ @echo " sdist to build source .tar.gz package"
@echo " lint to check Pylint sources with itself"
@echo " all to run all targets"
@@ -59,6 +60,10 @@ clean: /usr/bin/debuild /usr/bin/dh_pysupport
debuild clean
rm -rf $(PKG_DEB) ../pylint_*.changes ../pylint_*.build
+clobber:
+ hg purge -p
+ hg purge -a
+
/usr/bin/debuild:
sudo apt-get -y --force-yes install devscripts
@@ -67,4 +72,4 @@ clean: /usr/bin/debuild /usr/bin/dh_pysupport
all: clean lint tests docs sdist deb
-.PHONY: help tests docs deb sdist lint clean all
+.PHONY: help tests docs deb sdist lint clean clobber all