summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichal Nowikowski <godfryd@gmail.com>2014-07-26 11:14:29 +0200
committerMichal Nowikowski <godfryd@gmail.com>2014-07-26 11:14:29 +0200
commit2b61fb41831d91efa6d3701b5b629d0854b16fc6 (patch)
treeea1de76ea27d3fc517c0bf53ba60aaa9f643735c /Makefile
parent67a56a24f5553f3579a76cbee1c0f1df61e23437 (diff)
downloadpylint-2b61fb41831d91efa6d3701b5b629d0854b16fc6.tar.gz
Added initial Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..27f5ca9
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,48 @@
+# Makefile for handling various tasks of PyLint sources
+PYVE=pyve
+PIP=$(PYVE)/bin/pip
+TOX=$(PYVE)/bin/tox
+
+# this is default target, it should always be first in this Makefile
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " tests to run whole test suit of PyLint"
+ @echo " docs to generate all docs including man pages and exemplary pylintrc"
+ @echo " deb to build debian package"
+ @echo " lint to check Pylint sources with itself"
+ @echo " all to run all targets"
+
+
+$(PIP):
+ virtualenv $(PYVE)
+
+$(TOX): $(PIP)
+ $(PIP) install tox==1.7
+
+
+ifdef TOXENV
+toxparams?=-e $(TOXENV)
+endif
+
+tests: $(TOX)
+ $(TOX) $(toxparams)
+
+docs:
+ PATH=$(PATH):$(CURDIR) PYTHONPATH=$(CURDIR)/.. make all -C doc
+
+deb:
+ debuild -b -us -uc
+
+lint: $(PIP)
+ $(PIP) install .
+ $(PYVE)/bin/pylint lint.py
+
+clean:
+ rm -rf $(PYVE)
+ rm -rf .tox
+ make clean -C doc
+ debuild clean
+
+all: clean lint tests docs deb
+
+.PHONY: help tests docs deb lint clean all