summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClaudiu Popa <pcmanticore@gmail.com>2016-08-14 20:51:46 +0300
committerClaudiu Popa <pcmanticore@gmail.com>2016-08-14 21:01:58 +0300
commit31096db040b0050deb9602b8eb839b782edcfd86 (patch)
tree5649426cfb17e823c0404af003526c57647dc5e7
parent246d49f9e618d2391365de9e54e18d4a25034676 (diff)
downloadpylint-git-31096db040b0050deb9602b8eb839b782edcfd86.tar.gz
Move parts of the documentation into their own folder section.
-rw-r--r--doc/Makefile2
-rw-r--r--doc/development_guide/contribute.rst (renamed from doc/contribute.rst)0
-rw-r--r--doc/development_guide/index.rst (renamed from doc/development_guide.rst)0
-rwxr-xr-xdoc/exts/pylint_extensions.py2
-rwxr-xr-xdoc/exts/pylint_features.py2
-rw-r--r--doc/index.rst6
-rw-r--r--doc/make.bat12
-rw-r--r--doc/reference_guide/custom_checkers.rst (renamed from doc/custom_checkers.rst)0
-rw-r--r--doc/reference_guide/index.rst (renamed from doc/reference_guide.rst)0
-rw-r--r--doc/reference_guide/plugins.rst (renamed from doc/plugins.rst)5
-rw-r--r--doc/reference_guide/transform_plugins.rst (renamed from doc/transform_plugins.rst)0
-rw-r--r--doc/user_guide/ide-integration.rst (renamed from doc/ide-integration.rst)0
-rw-r--r--doc/user_guide/index.rst (renamed from doc/user_guide.rst)0
-rw-r--r--doc/user_guide/installation.rst (renamed from doc/installation.rst)0
-rw-r--r--doc/user_guide/message-control.rst (renamed from doc/message-control.rst)0
-rw-r--r--doc/user_guide/options.rst (renamed from doc/options.rst)0
-rw-r--r--doc/user_guide/output.rst (renamed from doc/output.rst)0
-rw-r--r--doc/user_guide/run.rst (renamed from doc/run.rst)0
18 files changed, 15 insertions, 14 deletions
diff --git a/doc/Makefile b/doc/Makefile
index c33d15447..2964a3282 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -36,7 +36,7 @@ help:
clean:
-rm -rf $(BUILDDIR)/*
- -rm -f features.rst
+ -rm -f reference_guide/features.rst
-rm -f extensions.rst
html: features.rst extensions.rst
diff --git a/doc/contribute.rst b/doc/development_guide/contribute.rst
index 7fae108d2..7fae108d2 100644
--- a/doc/contribute.rst
+++ b/doc/development_guide/contribute.rst
diff --git a/doc/development_guide.rst b/doc/development_guide/index.rst
index 29a20a966..29a20a966 100644
--- a/doc/development_guide.rst
+++ b/doc/development_guide/index.rst
diff --git a/doc/exts/pylint_extensions.py b/doc/exts/pylint_extensions.py
index e1d4f67ff..a371cd275 100755
--- a/doc/exts/pylint_extensions.py
+++ b/doc/exts/pylint_extensions.py
@@ -48,7 +48,7 @@ def builder_inited(app):
linter = PyLinter()
linter.load_plugin_modules(modules)
- extensions_doc = os.path.join(base_path, 'doc', 'extensions.rst')
+ extensions_doc = os.path.join(base_path, 'doc', 'reference_guide', 'extensions.rst')
with open(extensions_doc, 'w') as stream:
stream.write("Optional Pylint checkers in the extensions module\n")
stream.write("=================================================\n\n")
diff --git a/doc/exts/pylint_features.py b/doc/exts/pylint_features.py
index b81d1e4b6..5322c27cb 100755
--- a/doc/exts/pylint_features.py
+++ b/doc/exts/pylint_features.py
@@ -18,7 +18,7 @@ def builder_inited(app):
linter = PyLinter()
linter.load_default_plugins()
- features = os.path.join(base_path, 'doc', 'features.rst')
+ features = os.path.join(base_path, 'doc', 'reference_guide', 'features.rst')
with open(features, 'w') as stream:
stream.write("Pylint features\n")
stream.write("===============\n\n")
diff --git a/doc/index.rst b/doc/index.rst
index c2db2b7ce..c27f062f5 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -9,9 +9,9 @@ Pylint User Manual
intro
tutorial
- user_guide
- reference_guide
- development_guide
+ user_guide/index.rst
+ reference_guide/index.rst
+ development_guide/index.rst
faq
backlinks
diff --git a/doc/make.bat b/doc/make.bat
index 10ab0da00..7c754602b 100644
--- a/doc/make.bat
+++ b/doc/make.bat
@@ -47,12 +47,12 @@ if "%1" == "clean" (
if "%1" == "html" (
rm -f features.rst
- echo Pylint features > features.rst
- echo =============== >> features.rst
- echo >> features.rst
- echo .. generated by pylint --full-documentation >> features.rst
- echo >> features.rst
- python -m pylint --full-documentation >> features.rst
+ echo Pylint features > reference_guide/features.rst
+ echo =============== >> reference_guide/features.rst
+ echo >> reference_guide/features.rst
+ echo .. generated by pylint --full-documentation >> reference_guide/features.rst
+ echo >> reference_guide/features.rst
+ python -m pylint --full-documentation >> reference_guide/features.rst
%SPHINXBUILD% -b html %ALLSPHINXOPTS% %BUILDDIR%/html
if errorlevel 1 exit /b 1
echo.
diff --git a/doc/custom_checkers.rst b/doc/reference_guide/custom_checkers.rst
index 800006b0f..800006b0f 100644
--- a/doc/custom_checkers.rst
+++ b/doc/reference_guide/custom_checkers.rst
diff --git a/doc/reference_guide.rst b/doc/reference_guide/index.rst
index d17868992..d17868992 100644
--- a/doc/reference_guide.rst
+++ b/doc/reference_guide/index.rst
diff --git a/doc/plugins.rst b/doc/reference_guide/plugins.rst
index f1b639715..21926dbdb 100644
--- a/doc/plugins.rst
+++ b/doc/reference_guide/plugins.rst
@@ -6,7 +6,7 @@ Extending Pylint
Pylint provides support for writing two types of extensions. First, there
is the concept of **checkers**, which can be used for finding problems in your
-code. Secondly, there is also the concept of **transform plugin**, which is a
+code. Secondly, there is also the concept of **transform plugin**, which represents a
way through which the inference and the capabilities of Pylint can be enhanced
and tailored to a particular module, library of framework.
@@ -21,7 +21,8 @@ So a basic hello-world plugin can be implemented as:
def register(linter):
print 'Hello world'
-We can run this plugin by placing this module in the PYTHONPATH and invoking as:
+We can run this plugin by placing this module in the PYTHONPATH and invoking
+**pylint** as:
.. sourcecode:: bash
diff --git a/doc/transform_plugins.rst b/doc/reference_guide/transform_plugins.rst
index 39db6c2b1..39db6c2b1 100644
--- a/doc/transform_plugins.rst
+++ b/doc/reference_guide/transform_plugins.rst
diff --git a/doc/ide-integration.rst b/doc/user_guide/ide-integration.rst
index a480ae364..a480ae364 100644
--- a/doc/ide-integration.rst
+++ b/doc/user_guide/ide-integration.rst
diff --git a/doc/user_guide.rst b/doc/user_guide/index.rst
index 80fe2767e..80fe2767e 100644
--- a/doc/user_guide.rst
+++ b/doc/user_guide/index.rst
diff --git a/doc/installation.rst b/doc/user_guide/installation.rst
index b26c5a576..b26c5a576 100644
--- a/doc/installation.rst
+++ b/doc/user_guide/installation.rst
diff --git a/doc/message-control.rst b/doc/user_guide/message-control.rst
index 203229d1f..203229d1f 100644
--- a/doc/message-control.rst
+++ b/doc/user_guide/message-control.rst
diff --git a/doc/options.rst b/doc/user_guide/options.rst
index fdac04933..fdac04933 100644
--- a/doc/options.rst
+++ b/doc/user_guide/options.rst
diff --git a/doc/output.rst b/doc/user_guide/output.rst
index ea31d3cc3..ea31d3cc3 100644
--- a/doc/output.rst
+++ b/doc/user_guide/output.rst
diff --git a/doc/run.rst b/doc/user_guide/run.rst
index fb8ebdc4b..fb8ebdc4b 100644
--- a/doc/run.rst
+++ b/doc/user_guide/run.rst