summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBastien Vallet <bastien.vallet@gmail.com>2019-11-13 03:39:43 +0100
committerJosé Padilla <jpadilla@webapplicate.com>2019-11-12 21:39:43 -0500
commit8c93b2a314788798680febadfc5cac05b8dee5a5 (patch)
tree503f806f86b7e3b5024be1a8aedb06d2ef2fc27c /setup.py
parentc404473271a199a7445b0e2a348e47893988bbc7 (diff)
downloadpyjwt-8c93b2a314788798680febadfc5cac05b8dee5a5.tar.gz
Remove Python 2.7 compatibility (#457)
* Remove py27 support * [py27] Remove useless compatibility files
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index a33b1b8..907ac5e 100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,5 @@
-#!/usr/bin/env python
-# -*- coding: utf-8 -*-
+#!/usr/bin/env python3
+
import os
import re
import sys
@@ -60,14 +60,13 @@ setup(
"Natural Language :: English",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Topic :: Utilities",
],
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
+ python_requires=">=3, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
extras_require=EXTRAS_REQUIRE,
entry_points={"console_scripts": ["pyjwt = jwt.__main__:main"]},
options={"bdist_wheel": {"universal": "1"}},