summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé Padilla <jpadilla@webapplicate.com>2014-10-16 00:03:35 -0400
committerJosé Padilla <jpadilla@webapplicate.com>2014-10-16 00:03:35 -0400
commitfa441faa01aca0af8363e5994cda9b1830a56d8e (patch)
tree0a2a29bcd67028d833251004b144e019a230734a
parentd626f7e034c5a19627ba7a65dacc25d1e21d6573 (diff)
downloadpyjwt-fa441faa01aca0af8363e5994cda9b1830a56d8e.tar.gz
Add publish setup.py helper
-rwxr-xr-xsetup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 281bd2c..13fc3bd 100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
import os
+import sys
import re
from setuptools import setup
@@ -18,6 +19,15 @@ with open(os.path.join(os.path.dirname(__file__), 'README.md')) as readme:
long_description = readme.read()
+if sys.argv[-1] == 'publish':
+ os.system("python setup.py sdist upload")
+ os.system("python setup.py bdist_wheel upload")
+ print("You probably want to also tag the version now:")
+ print(" git tag -a %s -m 'version %s'" % (version, version))
+ print(" git push --tags")
+ sys.exit()
+
+
setup(
name='PyJWT',
version=version,