summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-12-24 23:39:26 +0200
committerGitHub <noreply@github.com>2021-12-24 16:39:26 -0500
commitdbb18432165bdc567e015511b3f3284f0f14cf05 (patch)
tree13b761f02284adc4213624b7e77e47e3a255e908 /setup.py
parent140817fbc48498ab8e72cbc82d57914f1606b457 (diff)
downloadpyflakes-dbb18432165bdc567e015511b3f3284f0f14cf05.tar.gz
Drop support for EOL Python 2.7 and 3.4-3.5 (#660)master
* Add support for Python 3.10 * Drop support for EOL Python 2.7 and 3.4-3.5
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 972718f..673a76d 100755
--- a/setup.py
+++ b/setup.py
@@ -42,21 +42,20 @@ setup(
author_email="code-quality@python.org",
url="https://github.com/PyCQA/pyflakes",
packages=["pyflakes", "pyflakes.scripts", "pyflakes.test"],
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=3.6',
classifiers=[
"Development Status :: 6 - Mature",
"Environment :: Console",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3 :: Only",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development",