summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES7
-rw-r--r--README.rst2
-rw-r--r--pycparser/__init__.py2
-rw-r--r--setup.py2
4 files changed, 10 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 3c33087..711c263 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,10 @@
++ Version 2.19 (2018.09.19)
+
+ - PR #277: Fix parsing of floating point literals
+ - PR #254: Add support for parsing empty structs
+ - PR #240: Fix enum formatting in generated C code (also #216)
+ - PR #222: Add support for #pragma in struct declarations
+
+ Version 2.18 (2017.07.04)
- PR #161 & #184: Update bundled PLY version to 3.10
diff --git a/README.rst b/README.rst
index 4af8160..df9025c 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
===============
-pycparser v2.18
+pycparser v2.19
===============
:Author: `Eli Bendersky <https://eli.thegreenplace.net/>`_
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index e57d5d8..b67389f 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -8,7 +8,7 @@
# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.18'
+__version__ = '2.19'
import io
from subprocess import check_output
diff --git a/setup.py b/setup.py
index 0fcc191..62eddc2 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,7 @@ setup(
C compilers or analysis tools.
""",
license='BSD',
- version='2.18',
+ version='2.19',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',