summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErlend E. Aasland <erlend.aasland@protonmail.com>2022-10-28 14:41:20 +0200
committerGitHub <noreply@github.com>2022-10-28 05:41:20 -0700
commitb13a06d22d05d47f115f3ed141f4fa727c654c6d (patch)
treeb63a8e8335e58115378014b61f7ef91820653327
parent0f6ef1efeee8c5fd5a7d1cde9117edeba2a08b82 (diff)
downloadpycparser-b13a06d22d05d47f115f3ed141f4fa727c654c6d.tar.gz
Add Python 3.11 as a supported version (#469)
* Add Python 3.11 as a supported version Fixes #468 * Address review: add Python 3.11 to CI test matrix
-rw-r--r--.github/workflows/ci.yml2
-rw-r--r--setup.py1
2 files changed, 2 insertions, 1 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 51bd891..08ba7e5 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -13,7 +13,7 @@ jobs:
runs-on: ${{ matrix.os }}
strategy:
matrix:
- python-version: ["2.7", "3.6", "3.7", "3.8", "3.9", "3.10"]
+ python-version: ["2.7", "3.6", "3.7", "3.8", "3.9", "3.10", "3.11"]
os: [ubuntu-latest, macos-latest, windows-latest]
steps:
diff --git a/setup.py b/setup.py
index fbcff22..8dc0cdb 100644
--- a/setup.py
+++ b/setup.py
@@ -62,6 +62,7 @@ setup(
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
],
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
packages=['pycparser', 'pycparser.ply'],