summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Bendersky <eliben@gmail.com>2015-04-21 17:37:54 -0700
committerEli Bendersky <eliben@gmail.com>2015-04-21 17:37:54 -0700
commitf1b2db2a64afbbc2397cc860d4088317113a8c5f (patch)
treedfcbebadc47289c633ce3c5bcde598fab3fae7c0
parentdf48f15934ab0bf4a06d8f5c35711691796e07e8 (diff)
downloadpycparser-release_v2.12.tar.gz
Release 2.12release_v2.12
-rw-r--r--CHANGES6
-rw-r--r--README.rst2
-rw-r--r--pycparser/__init__.py2
-rw-r--r--setup.py2
4 files changed, 9 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index d3dab43..ae7a175 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,9 @@
++ Version 2.12 (21.04.2015)
+
+ - This is a fix release for 2.11; the memory optimization with __slots__ on
+ Coord and AST nodes didn't take weakrefs into account, which broke cffi and
+ its many dependents (iseue #76). Fixed by adding __weakref__ to __slots__.
+
+ Version 2.11 (21.04.2015)
- Add support for C99 6.5.3.7 p7 - qualifiers within array dimensions in
diff --git a/README.rst b/README.rst
index 6934561..095f3a1 100644
--- a/README.rst
+++ b/README.rst
@@ -1,5 +1,5 @@
===============
-pycparser v2.11
+pycparser v2.12
===============
:Author: `Eli Bendersky <http://eli.thegreenplace.net>`_
diff --git a/pycparser/__init__.py b/pycparser/__init__.py
index 488704d..ae2b999 100644
--- a/pycparser/__init__.py
+++ b/pycparser/__init__.py
@@ -8,7 +8,7 @@
# License: BSD
#-----------------------------------------------------------------
__all__ = ['c_lexer', 'c_parser', 'c_ast']
-__version__ = '2.11'
+__version__ = '2.12'
from subprocess import Popen, PIPE
from .c_parser import CParser
diff --git a/setup.py b/setup.py
index ee50f53..0c53552 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ setup(
C compilers or analysis tools.
""",
license='BSD',
- version='2.11',
+ version='2.12',
author='Eli Bendersky',
maintainer='Eli Bendersky',
author_email='eliben@gmail.com',