summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 15 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index cffb9e8..6405ca9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,19 +1,20 @@
from setuptools import setup, find_packages
setup(
- name = "Pycco",
- version = "0.1.2",
- description = """A Python port of Docco: the original quick-and-dirty,
+ name="Pycco",
+ version="0.4.1",
+ description="""A Python port of Docco: the original quick-and-dirty,
hundred-line-long, literate-programming-style documentation generator.
""",
- author = "Nick Fitzgerald",
- author_email = "fitzgen@gmail.com",
- url = "http://fitzgen.github.com/pycco",
- packages = find_packages(),
- entry_points = {
- 'console_scripts': [
- 'pycco = pycco.main:main',
- ]
- },
- install_requires = ['markdown', 'pygments', 'pystache'],
- )
+ author="Zach Smith",
+ author_email="subsetpark@gmail.com",
+ url="https://pycco-docs.github.io/pycco/",
+ packages=find_packages(),
+ entry_points={
+ 'console_scripts': [
+ 'pycco = pycco.main:main',
+ ]
+ },
+ install_requires=['markdown', 'pygments', 'pystache', 'smartypants'],
+ extras_require={'monitoring': 'watchdog'},
+)