summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach Smith <zd@zdsmith.com>2018-04-25 20:21:56 -0400
committerZach Smith <zd@zdsmith.com>2018-04-25 20:21:56 -0400
commita761ddff2bc6eb36bf9ef75733bb4dc4177c5d7a (patch)
tree65ac9fd0e1554164502ed15b63a7e7178bb5dd7a
parent1347afdb2e02ef2cb8557978fa39f72930436128 (diff)
downloadpycco-a761ddff2bc6eb36bf9ef75733bb4dc4177c5d7a.tar.gz
Update requirements
-rw-r--r--requirements.test.txt6
-rw-r--r--requirements.txt4
-rw-r--r--setup.py10
3 files changed, 12 insertions, 8 deletions
diff --git a/requirements.test.txt b/requirements.test.txt
index 5db5948..f8e9871 100644
--- a/requirements.test.txt
+++ b/requirements.test.txt
@@ -1,3 +1,3 @@
-hypothesis==1.18.1
-pytest-cov==2.2.0
-coveralls==1.1
+hypothesis==3.56.5
+pytest-cov==2.5.1
+coveralls==1.3.0
diff --git a/requirements.txt b/requirements.txt
index 38964da..7980f04 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,3 +1,3 @@
pystache==0.5.4
-Pygments==2.0.2
-markdown==2.6.3
+Pygments==2.2.0
+markdown==2.6.11
diff --git a/setup.py b/setup.py
index c9a38e0..8fc15c2 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,15 @@
from setuptools import setup, find_packages
+description = (
+ "A Python port of Docco: the original quick-and-dirty, "
+ "hundred-line-long, literate-programming-style documentation "
+ "generator."
+)
+
setup(
name="Pycco",
version="0.5.1",
- description="""A Python port of Docco: the original quick-and-dirty,
- hundred-line-long, literate-programming-style documentation generator.
- """,
+ description=description,
author="Zach Smith",
author_email="subsetpark@gmail.com",
url="https://pycco-docs.github.io/pycco/",