summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach Smith <zd@zdsmith.com>2015-12-28 14:53:12 -0500
committerZach Smith <zd@zdsmith.com>2015-12-28 14:53:12 -0500
commit0d85d161977bcfd9bb26b930ca13e66fd0e3786f (patch)
tree12728bbd169f91eb6fbf29cec542fd1d8df48729
parentb55033371b55b7d9410eee01d036531da3e42784 (diff)
downloadpycco-0d85d161977bcfd9bb26b930ca13e66fd0e3786f.tar.gz
(0.4)0.4
-rw-r--r--CONTRIBUTING.md9
-rw-r--r--LICENSE3
-rw-r--r--README.md6
-rw-r--r--setup.py8
4 files changed, 11 insertions, 15 deletions
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
index 4351196..eafb7ed 100644
--- a/CONTRIBUTING.md
+++ b/CONTRIBUTING.md
@@ -1,12 +1,7 @@
# Contributing to Pycco
-This project currently lacks an active maintainer.
-
-The original author (Nick Fitzgerald) no longer maintains this project actively
-and the current maintainer (Trey Hunner) no longer uses Pycco actively.
+[Zach Smith](http://zdsmith.com) is the current maintainer of this project.
## Help Us Out
-If you would like to help merge pull requests and manage issues email
-Trey Hunner and Nick Fitzgerald so you can be granted access to manage the
-repository.
+Feel free to contribute by opening a pull request on this project's [GitHub repo](https://github.com/pycco-docs/pycco). All requests with documented and tested code will be gladly reviewed.
diff --git a/LICENSE b/LICENSE
index fbb0a92..de4c3a7 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,5 @@
Copyright (c) 2010 Nick Fitzgerald
+Copyright (c) 2016 Zachary Smith
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
@@ -19,4 +20,4 @@ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
Parts of Pycco are taken from Docco, see http://github.com/jashkenas/docco for
-more information. \ No newline at end of file
+more information.
diff --git a/README.md b/README.md
index 9cad492..73bca0a 100644
--- a/README.md
+++ b/README.md
@@ -16,7 +16,7 @@ Pycco is a Python port of Docco: the original quick-and-dirty, hundred-line-
long, literate-programming-style documentation generator. For more information,
see:
-http://fitzgen.github.com/pycco/
+https://pycco-docs.github.io/pycco/
Others:
@@ -26,5 +26,5 @@ Ruby - http://rtomayko.github.com/rocco/
Sh - http://rtomayko.github.com/shocco/
-[![Build Status](https://travis-ci.org/subsetpark/pycco.svg?branch=hypothesis)](https://travis-ci.org/subsetpark/pycco)
-[![Coverage Status](https://coveralls.io/repos/subsetpark/pycco/badge.svg?branch=hypothesis&service=github)](https://coveralls.io/github/subsetpark/pycco?branch=hypothesis)
+[![Build Status](https://travis-ci.org/pycco-docs/pycco.svg?branch=master)](https://travis-ci.org/pycco-docs/pycco)
+[![Coverage Status](https://coveralls.io/repos/pycco-docs/pycco/badge.svg?branch=master&service=github)](https://coveralls.io/github/pycco-docs/pycco?branch=master)
diff --git a/setup.py b/setup.py
index 28b20b1..1ba701b 100644
--- a/setup.py
+++ b/setup.py
@@ -2,13 +2,13 @@ from setuptools import setup, find_packages
setup(
name="Pycco",
- version="0.3.1",
+ version="0.4",
description="""A Python port of Docco: the original quick-and-dirty,
hundred-line-long, literate-programming-style documentation generator.
""",
- author="Nick Fitzgerald",
- author_email="fitzgen@gmail.com",
- url="http://fitzgen.github.com/pycco",
+ author="Zach Smith",
+ author_email="subsetpark@gmail.com",
+ url="https://pycco-docs.github.io/pycco/",
packages=find_packages(),
entry_points={
'console_scripts': [