summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2019-11-23 09:57:24 +0100
committerGitHub <noreply@github.com>2019-11-23 09:57:24 +0100
commit2b646e07d5d83f0892fa2a809ae4c981430cb12c (patch)
tree20b10450bced84c425ca0735b4ee7202e68ee1ec /setup.py
parent788af3c44edc2ebd079eda3f7a4ae2f9931446fd (diff)
parentf10434e31f9293c4e739ac6c5d1519f407bd1540 (diff)
downloadpyasn1-git-2b646e07d5d83f0892fa2a809ae4c981430cb12c.tar.gz
Merge branch 'master' into streamoptimum37
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 6 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index fa0a876..5606175 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,7 @@
#
import os
import sys
+import unittest
classifiers = """\
Development Status :: 5 - Production/Stable
@@ -20,17 +21,12 @@ License :: OSI Approved :: BSD License
Natural Language :: English
Operating System :: OS Independent
Programming Language :: Python :: 2
-Programming Language :: Python :: 2.4
-Programming Language :: Python :: 2.5
-Programming Language :: Python :: 2.6
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
-Programming Language :: Python :: 3.2
-Programming Language :: Python :: 3.3
-Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
+Programming Language :: Python :: 3.8
Topic :: Communications
Topic :: Software Development :: Libraries :: Python Modules
"""
@@ -49,8 +45,8 @@ def howto_install_setuptools():
""")
-if sys.version_info[:2] < (2, 4):
- print("ERROR: this package requires Python 2.4 or later!")
+if sys.version_info[:2] < (2, 7):
+ print("ERROR: this package requires Python 2.7 or later!")
sys.exit(1)
try:
@@ -88,13 +84,8 @@ params.update({
'pyasn1.codec.ber',
'pyasn1.codec.cer',
'pyasn1.codec.der',
- 'pyasn1.codec.native']})
-
-# handle unittest discovery feature
-try:
- import unittest2 as unittest
-except ImportError:
- import unittest
+ 'pyasn1.codec.native'],
+ 'python_requires': '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*'})
class PyTest(Command):