summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2014-12-05 21:24:16 -0500
committerDonald Stufft <donald@stufft.io>2014-12-05 21:24:16 -0500
commit3aaea256a0e73b6f2c585edf53fce52a15b49322 (patch)
tree2a05673830fe037a81dc282b3c866938d15458db /tox.ini
parentf94682bd265391d29dcae08dfcf5a2964ed0ed0e (diff)
downloadpy-bcrypt-git-3aaea256a0e73b6f2c585edf53fce52a15b49322.tar.gz
Enable coverage testing and require 100% coverage
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini4
1 files changed, 3 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 6602901..0143891 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,10 +4,12 @@ envlist = py26,py27,pypy,py32,py33,py34,pep8,py3pep8
[testenv]
# If you add a new dep here you probably need to add it in setup.py as well
deps =
+ coverage
mock
pytest
commands =
- py.test --strict {posargs}
+ coverage run -m pytest --strict {posargs}
+ coverage report -m --fail-under 100
[testenv:pep8]
deps =