summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2014-06-20 17:17:57 +0100
committerAsk Solem <ask@celeryproject.org>2014-06-20 17:17:57 +0100
commit521c74bb73aeff97aa2941665de88680add0b181 (patch)
treedbe582ceefa7ab566e5f815f447bf2cf900a67e4 /setup.py
parent6b945b7065bd3bc53142e2d3f1d520d6f4a3d2de (diff)
downloadpy-amqp-521c74bb73aeff97aa2941665de88680add0b181.tar.gz
Drops Python 2.6 support and adds support for Python 3.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 341dd4e..12e8dbd 100644
--- a/setup.py
+++ b/setup.py
@@ -15,8 +15,8 @@ import os
import sys
import codecs
-if sys.version_info < (2, 6):
- raise Exception('amqp requires Python 2.6 or higher.')
+if sys.version_info < (2, 7):
+ raise Exception('amqp requires Python 2.7 or higher.')
NAME = 'amqp'
entrypoints = {}
@@ -28,10 +28,10 @@ classes = """
Development Status :: 5 - Production/Stable
Programming Language :: Python
Programming Language :: Python :: 2
- Programming Language :: Python :: 2.6
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.3
+ Programming Language :: Python :: 3.4
License :: OSI Approved :: GNU Library or \
Lesser General Public License (LGPL)
Intended Audience :: Developers