summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKian-Meng, Ang <kianmeng@cpan.org>2021-11-06 13:00:29 +0800
committerAsif Saif Uddin <auvipy@gmail.com>2021-11-06 12:56:36 +0600
commitc1fe574f64e5afc09c22ff5c4f655a0168d8629f (patch)
tree46397fce4b46f2c862e67aac31ddcec728e5300e
parentfa4c4bb5a34d73acf1fe8860c6967a35fce5135d (diff)
downloadpy-amqp-c1fe574f64e5afc09c22ff5c4f655a0168d8629f.tar.gz
Fix typos
-rw-r--r--Changelog2
-rw-r--r--Makefile2
-rw-r--r--amqp/abstract_channel.py2
-rw-r--r--amqp/channel.py2
-rw-r--r--amqp/connection.py2
-rw-r--r--amqp/transport.py4
-rw-r--r--t/integration/test_integration.py14
7 files changed, 14 insertions, 14 deletions
diff --git a/Changelog b/Changelog
index 48ee3e1..7aff774 100644
--- a/Changelog
+++ b/Changelog
@@ -167,7 +167,7 @@ Code Cleanups & Improvements:
:release-by: Asif Saif Uddin
- Fix buffer overflow in frame_writer after frame_max is increased. `frame_writer`
-allocates a `bytearray` on intialization with a length based on the `connection.frame_max`
+allocates a `bytearray` on initialization with a length based on the `connection.frame_max`
value. If `connection.frame_max` is changed to a larger value, this causes an
error like `pack_into requires a buffer of at least 408736 bytes`.
diff --git a/Makefile b/Makefile
index 69ef42c..fcd8bf4 100644
--- a/Makefile
+++ b/Makefile
@@ -39,7 +39,7 @@ help:
@echo "readme - Regenerate README.rst file."
@echo "contrib - Regenerate CONTRIBUTING.rst file"
@echo "clean-dist --------- - Clean all distribution build artifacts."
- @echo " clean-git-force - Remove all uncomitted files."
+ @echo " clean-git-force - Remove all uncommitted files."
@echo " clean ------------ - Non-destructive clean"
@echo " clean-pyc - Remove .pyc/__pycache__ files"
@echo " clean-docs - Remove documentation build artifacts."
diff --git a/amqp/abstract_channel.py b/amqp/abstract_channel.py
index f09c2ee..6234b19 100644
--- a/amqp/abstract_channel.py
+++ b/amqp/abstract_channel.py
@@ -68,7 +68,7 @@ class AbstractChannel:
def close(self):
"""Close this Channel or Connection."""
- raise NotImplementedError('Must be overriden in subclass')
+ raise NotImplementedError('Must be overridden in subclass')
def wait(self, method, callback=None, timeout=None, returns_tuple=False):
p = ensure_promise(callback)
diff --git a/amqp/channel.py b/amqp/channel.py
index dcf02c0..b271820 100644
--- a/amqp/channel.py
+++ b/amqp/channel.py
@@ -1380,7 +1380,7 @@ class Channel(AbstractChannel):
False, the delivery tag refers to a single message.
If the multiple field is True, and the delivery tag
is zero, tells the server to acknowledge all
- outstanding mesages.
+ outstanding messages.
RULE:
diff --git a/amqp/connection.py b/amqp/connection.py
index e8aaacf..5b3a4d1 100644
--- a/amqp/connection.py
+++ b/amqp/connection.py
@@ -104,7 +104,7 @@ class Connection(AbstractChannel):
When "confirm_publish" is set to True, the channel is put to
confirm mode. In this mode, each published message is
- confirmed using Publisher confirms RabbitMQ extention.
+ confirmed using Publisher confirms RabbitMQ extension.
"""
Channel = Channel
diff --git a/amqp/transport.py b/amqp/transport.py
index 7056be8..701c34c 100644
--- a/amqp/transport.py
+++ b/amqp/transport.py
@@ -256,7 +256,7 @@ class _AbstractTransport:
def _read(self, n, initial=False):
"""Read exactly n bytes from the peer."""
- raise NotImplementedError('Must be overriden in subclass')
+ raise NotImplementedError('Must be overridden in subclass')
def _setup_transport(self):
"""Do any additional initialization of the class."""
@@ -268,7 +268,7 @@ class _AbstractTransport:
def _write(self, s):
"""Completely write a string to the peer."""
- raise NotImplementedError('Must be overriden in subclass')
+ raise NotImplementedError('Must be overridden in subclass')
def close(self):
if self.sock is not None:
diff --git a/t/integration/test_integration.py b/t/integration/test_integration.py
index 951bf9c..1ce3851 100644
--- a/t/integration/test_integration.py
+++ b/t/integration/test_integration.py
@@ -114,7 +114,7 @@ def build_frame_type_3(channel, body):
class DataComparator:
# Comparator used for asserting serialized data. It can be used
- # in cases when direct comparision of bytestream cannot be used
+ # in cases when direct comparison of bytestream cannot be used
# (mainly cases of Table type where order of items can vary)
def __init__(self, argsig, items):
self.argsig = argsig
@@ -367,7 +367,7 @@ class test_connection:
@patch('amqp.Connection._on_blocked')
def test_connecion_ignore_methods_during_close(self, on_blocked_mock):
# Test checking that py-amqp will discard any received methods
- # except Close and Close-OK after sending Connecion.Close method
+ # except Close and Close-OK after sending Connection.Close method
# to server.
frame_writer_cls_mock = Mock()
frame_writer_mock = frame_writer_cls_mock()
@@ -601,7 +601,7 @@ class test_channel:
callback_mock.assert_called_once()
def test_basic_publish(self):
- # Test verifing publishing message.
+ # Test verifying publishing message.
frame_writer_cls_mock = Mock()
conn = Connection(frame_writer=frame_writer_cls_mock)
with patch.object(conn, 'Transport') as transport_mock:
@@ -621,7 +621,7 @@ class test_channel:
)
def test_consume_no_consumer_tag(self):
- # Test verifing starting consuming without specified consumer_tag
+ # Test verifying starting consuming without specified consumer_tag
callback_mock = Mock()
frame_writer_cls_mock = Mock()
conn = Connection(frame_writer=frame_writer_cls_mock)
@@ -652,7 +652,7 @@ class test_channel:
assert ret == 'amq.ctag-PCmzXGkhCw_v0Zq7jXyvkg'
def test_consume_with_consumer_tag(self):
- # Test verifing starting consuming with specified consumer_tag
+ # Test verifying starting consuming with specified consumer_tag
callback_mock = Mock()
frame_writer_cls_mock = Mock()
conn = Connection(frame_writer=frame_writer_cls_mock)
@@ -745,7 +745,7 @@ class test_channel:
assert excinfo.value.method_sig == spec.Exchange.Declare
# Client is sending to broker:
# 1. Exchange Declare
- # 2. Connection.CloseOk as reply to received Connecton.Close
+ # 2. Connection.CloseOk as reply to received Connection.Close
frame_writer_calls = [
call(
1, 1, spec.Queue.Declare,
@@ -1024,7 +1024,7 @@ class test_channel:
assert excinfo.value.method_sig == spec.Exchange.Declare
# Client is sending to broker:
# 1. Exchange Declare
- # 2. Connection.CloseOk as reply to received Connecton.Close
+ # 2. Connection.CloseOk as reply to received Connection.Close
frame_writer_calls = [
call(
1, 1, spec.Exchange.Declare,