summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saif Uddin (Auvi) <auvipy@gmail.com>2021-04-01 12:11:33 +0600
committerAsif Saif Uddin (Auvi) <auvipy@gmail.com>2021-04-01 12:11:33 +0600
commit7300741f9fc202083e87abd10e1cb38c28efad92 (patch)
tree6765e6f549c521e09aa2d10a0b8df9b6cfea0bc4
parent4dad914be084af6b1304e4290e83a6f018d75268 (diff)
downloadpy-amqp-7300741f9fc202083e87abd10e1cb38c28efad92.tar.gz
fix errors
-rw-r--r--README.rst12
-rw-r--r--setup.py1
2 files changed, 8 insertions, 5 deletions
diff --git a/README.rst b/README.rst
index 159bbf5..6a0b737 100644
--- a/README.rst
+++ b/README.rst
@@ -146,14 +146,16 @@ Currently speedups can be installed:
1. using source package (using ``--no-binary`` switch):
-.. code-block::
-CELERY_ENABLE_SPEEDUPS=true pip install --no-binary :all: amqp
+.. code:: shell
+
+ CELERY_ENABLE_SPEEDUPS=true pip install --no-binary :all: amqp
2. building directly source code:
-.. code-block::
-CELERY_ENABLE_SPEEDUPS=true python setup.py install
+.. code:: shell
+
+ CELERY_ENABLE_SPEEDUPS=true python setup.py install
Further
=======
@@ -202,7 +204,7 @@ Further
:target: https://pypi.org/project/amqp/
py-amqp as part of the Tidelift Subscription
-=======
+============================================
The maintainers of py-amqp and thousands of other packages are working with Tidelift to deliver commercial support and maintenance for the open source dependencies you use to build your applications. Save time, reduce risk, and improve code health, while paying the maintainers of the exact dependencies you use. [Learn more.](https://tidelift.com/subscription/pkg/pypi-amqp?utm_source=pypi-amqp&utm_medium=referral&utm_campaign=readme&utm_term=repo)
diff --git a/setup.py b/setup.py
index ffa7311..4224142 100644
--- a/setup.py
+++ b/setup.py
@@ -122,6 +122,7 @@ setuptools.setup(
version=meta['version'],
description=meta['doc'],
long_description=(here / 'README.rst').read_text(),
+ long_description_content_type="text/x-rst",
keywords='amqp rabbitmq cloudamqp messaging',
author=meta['author'],
author_email=meta['contact'],