summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2016-05-26 13:45:15 -0700
committerAsk Solem <ask@celeryproject.org>2016-05-26 13:46:09 -0700
commita0c96ff8584ec59659656eed3e0e42d29f52dade (patch)
tree061bbd11ebd6fcaff9b01ebfb784db40a95d9383
parent39a05be8060f50fc4c2c98ac2c52a8119ce398e8 (diff)
downloadpy-amqp-2.0.0.tar.gz
Bumps version to 2.0.0 and updates Changelogv2.0.0
-rw-r--r--Changelog21
-rw-r--r--amqp/__init__.py2
-rw-r--r--docs/includes/introduction.txt2
-rw-r--r--setup.py1
4 files changed, 23 insertions, 3 deletions
diff --git a/Changelog b/Changelog
index d8f9824..c048e8b 100644
--- a/Changelog
+++ b/Changelog
@@ -9,6 +9,8 @@ http://code.google.com/p/py-amqplib/source/browse/CHANGES
2.0.0
=====
+:release-date: 2016-05-26 1:44 PM PDT
+:release-by: Ask Solem
- No longer supports Python 2.6
@@ -38,11 +40,30 @@ http://code.google.com/p/py-amqplib/source/browse/CHANGES
Contributed by Vic Kumar.
+- Contributions by:
+
+ Adrien Guinet
+ Andrea Rosa
+ Artyom Koval
+ Corey Farwell
+ Craig Jellick
+ Dallas Marlow
+ Davanum Srinivas
+ Federico Ficarelli
+ Jared Lewis
+ Rémy Greinhofer
+ Rongze Zhu
+ Yury Selivanov
+ Vic Kumar
+ Vladimir Bolshakov
+ :github_user:`lezeroq`
+
.. _version-1.4.9:
1.4.9
=====
:release-date: 2016-01-08 5:50 PM PST
+:release-by: Ask Solem
- Fixes compatibility with Linux/OS X instances where the ``ctypes`` module
does not exist.
diff --git a/amqp/__init__.py b/amqp/__init__.py
index 285e4fa..f86e25e 100644
--- a/amqp/__init__.py
+++ b/amqp/__init__.py
@@ -22,7 +22,7 @@ version_info_t = namedtuple(
'version_info_t', ('major', 'minor', 'micro', 'releaselevel', 'serial'),
)
-VERSION = version_info = version_info_t(2, 0, 0, 'rc2', '')
+VERSION = version_info = version_info_t(2, 0, 0, '', '')
__version__ = '{0.major}.{0.minor}.{0.micro}{0.releaselevel}'.format(VERSION)
__author__ = 'Barry Pederson'
diff --git a/docs/includes/introduction.txt b/docs/includes/introduction.txt
index 3c6609d..a1dc5a6 100644
--- a/docs/includes/introduction.txt
+++ b/docs/includes/introduction.txt
@@ -1,4 +1,4 @@
-:Version: 2.0.0rc2
+:Version: 2.0.0
:Web: http://amqp.readthedocs.org/
:Download: http://pypi.python.org/pypi/amqp/
:Source: http://github.com/celery/py-amqp/
diff --git a/setup.py b/setup.py
index a923312..5819d61 100644
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,6 @@ classes = """
License :: OSI Approved :: GNU Library or \
Lesser General Public License (LGPL)
Intended Audience :: Developers
- License :: OSI Approved :: BSD License
Operating System :: OS Independent
"""
classifiers = [s.strip() for s in classes.split('\n') if s]