summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saif Uddin <auvipy@gmail.com>2022-01-10 11:57:32 +0600
committerGitHub <noreply@github.com>2022-01-10 11:57:32 +0600
commit59af2445549e4e1bb87a932cbb4d196629f16dd6 (patch)
tree12559251f4412f58740c70831c402a06128b8511
parent557d98a7d27e171ce7b22e2e3a56baf805ad8e52 (diff)
downloadpy-amqp-master.tar.gz
start dropping python 3.6 (#387)master
* start dropping python 3.6 mainly for 5.1.0 release * update tidelift alignment config CI (#375) * update tidelift alignment config CI * update tidelift CLI properly * not needed on PR * drop python from all matrix
-rw-r--r--.github/workflows/ci.yaml4
-rw-r--r--Makefile12
-rw-r--r--setup.py1
-rw-r--r--tox.ini8
4 files changed, 7 insertions, 18 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index bf944c8..ff79ea4 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -7,7 +7,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6,3.7,3.8,3.9,pypy3]
+ python-version: [3.7,3.8,3.9,pypy3]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v2.3.4
@@ -26,7 +26,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6,3.7,3.8,3.9,pypy3]
+ python-version: [3.7,3.8,3.9,pypy3]
steps:
- name: Check out code from GitHub
uses: actions/checkout@v2.3.4
diff --git a/Makefile b/Makefile
index fcd8bf4..9bb3c43 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,6 @@ GIT=git
TOX=tox
ICONV=iconv
FLAKE8=flake8
-FLAKEPLUS=flakeplus
PYDOCSTYLE=pydocstyle
SPHINX2RST=sphinx2rst
@@ -19,7 +18,7 @@ CONTRIBUTING=CONTRIBUTING.rst
CONTRIBUTING_SRC="docs/contributing.rst"
SPHINX_HTMLDIR="${SPHINX_BUILDDIR}/html"
DOCUMENTATION=Documentation
-FLAKEPLUSTARGET=2.7
+
all: help
@@ -34,7 +33,6 @@ help:
@echo " contribcheck - Check CONTRIBUTING.rst encoding"
@echo " flakes -------- - Check code for syntax and style errors."
@echo " flakecheck - Run flake8 on the source code."
- @echo " flakepluscheck - Run flakeplus on the source code."
@echo " pep257check - Run pep257 on the source code."
@echo "readme - Regenerate README.rst file."
@echo "contrib - Regenerate CONTRIBUTING.rst file"
@@ -85,16 +83,10 @@ flakecheck:
flakediag:
-$(MAKE) flakecheck
-flakepluscheck:
- $(FLAKEPLUS) --$(FLAKEPLUSTARGET) "$(PROJ)" "$(TESTDIR)"
-
-flakeplusdiag:
- -$(MAKE) flakepluscheck
-
pep257check:
$(PYDOCSTYLE) "$(PROJ)"
-flakes: flakediag flakeplusdiag pep257check
+flakes: flakediag pep257check
clean-readme:
-rm -f $(README)
diff --git a/setup.py b/setup.py
index 23a2245..9f6c44d 100644
--- a/setup.py
+++ b/setup.py
@@ -17,7 +17,6 @@ classes = """
Programming Language :: Python
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
- Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
diff --git a/tox.ini b/tox.ini
index 6fd950e..295f89c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,9 +1,8 @@
[tox]
envlist =
- {pypy3,3.6,3.7,3.8,3.9,3.10}-unit
- {pypy3,3.6,3.7,3.8,3.9.3.10}-integration-rabbitmq
+ {pypy3,3.7,3.8,3.9,3.10}-unit
+ {pypy3,3.7,3.8,3.9.3.10}-integration-rabbitmq
flake8
- flakeplus
apicheck
pydocstyle
requires = tox-docker>=2.0
@@ -15,7 +14,7 @@ deps=
-r{toxinidir}/requirements/test-ci.txt
apicheck,linkcheck: -r{toxinidir}/requirements/docs.txt
- flake8,flakeplus,pydocstyle: -r{toxinidir}/requirements/pkgutils.txt
+ flake8,pydocstyle: -r{toxinidir}/requirements/pkgutils.txt
sitepackages = False
recreate = False
commands =
@@ -24,7 +23,6 @@ commands =
basepython =
flake8,apicheck,linkcheck,pydocstyle: python3.8
pypy3: pypy
- 3.6: python3.6
3.7: python3.7
3.8: python3.8
3.9: python3.9