summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2022-10-25 12:26:20 +0200
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2022-10-25 12:37:23 +0200
commit12700a5f0267d2cf3537b2af313d1e5bb0d36fb2 (patch)
treec59a098d30998c28fb9ad6246b7331b08c27c013
parent271dd1fce7d00ebc740680f1649765e331514a41 (diff)
downloadpsycopg2-12700a5f0267d2cf3537b2af313d1e5bb0d36fb2.tar.gz
Build packages for Python 3.11
-rw-r--r--.github/workflows/packages.yml4
-rw-r--r--.github/workflows/tests.yml6
-rw-r--r--NEWS6
-rw-r--r--doc/src/install.rst2
-rwxr-xr-xscripts/build/build_macos_arm64.sh2
-rw-r--r--setup.py1
6 files changed, 14 insertions, 7 deletions
diff --git a/.github/workflows/packages.yml b/.github/workflows/packages.yml
index f0e10f9..ab80094 100644
--- a/.github/workflows/packages.yml
+++ b/.github/workflows/packages.yml
@@ -79,7 +79,7 @@ jobs:
docker run --rm
-e PLAT=${{ matrix.tag }}_${{ matrix.arch }}
-e PACKAGE_NAME=psycopg2-binary
- -e PYVERS="cp36-cp36m cp37-cp37m cp38-cp38 cp39-cp39 cp310-cp310"
+ -e PYVERS="cp36-cp36m cp37-cp37m cp38-cp38 cp39-cp39 cp310-cp310 cp311-cp311"
-e PSYCOPG2_TESTDB=postgres
-e PSYCOPG2_TESTDB_HOST=172.17.0.1
-e PSYCOPG2_TESTDB_USER=postgres
@@ -117,7 +117,7 @@ jobs:
strategy:
fail-fast: false
matrix:
- python-version: ['3.6', '3.7', '3.8', '3.9', '3.10']
+ python-version: ['3.6', '3.7', '3.8', '3.9', '3.10', '3.11']
steps:
- name: Checkout repos
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 5229ada..c89140c 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -18,15 +18,15 @@ jobs:
- {python: "3.8", postgres: "12"}
- {python: "3.9", postgres: "13"}
- {python: "3.10", postgres: "14"}
- - {python: "3.11-dev", postgres: "15rc1"}
+ - {python: "3.11", postgres: "15"}
# Opposite extremes of the supported Py/PG range, other architecture
- - {python: "3.6", postgres: "15rc1", architecture: "x86"}
+ - {python: "3.6", postgres: "15", architecture: "x86"}
- {python: "3.7", postgres: "14", architecture: "x86"}
- {python: "3.8", postgres: "13", architecture: "x86"}
- {python: "3.9", postgres: "12", architecture: "x86"}
- {python: "3.10", postgres: "11", architecture: "x86"}
- - {python: "3.11-dev", postgres: "10", architecture: "x86"}
+ - {python: "3.11", postgres: "10", architecture: "x86"}
env:
PSYCOPG2_TESTDB: postgres
diff --git a/NEWS b/NEWS
index 62a70fc..2d9d47d 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,12 @@
Current release
---------------
+What's new in psycopg 2.9.5
+^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+- Add support for Python 3.11.
+
+
What's new in psycopg 2.9.4
^^^^^^^^^^^^^^^^^^^^^^^^^^^
diff --git a/doc/src/install.rst b/doc/src/install.rst
index 8d7e020..76748cb 100644
--- a/doc/src/install.rst
+++ b/doc/src/install.rst
@@ -131,7 +131,7 @@ The current `!psycopg2` implementation supports:
..
NOTE: keep consistent with setup.py and the /features/ page.
-- Python versions from 3.6 to 3.10
+- Python versions from 3.6 to 3.11
- PostgreSQL server versions from 7.4 to 15
- PostgreSQL client library version from 9.1
diff --git a/scripts/build/build_macos_arm64.sh b/scripts/build/build_macos_arm64.sh
index fa18590..4ad7f2b 100755
--- a/scripts/build/build_macos_arm64.sh
+++ b/scripts/build/build_macos_arm64.sh
@@ -10,7 +10,7 @@
set -euo pipefail
set -x
-python_versions="3.8.10 3.9.13 3.10.5"
+python_versions="3.8.10 3.9.13 3.10.5 3.11"
postgres_version=14
# Move to the root of the project
diff --git a/setup.py b/setup.py
index 85379f5..7a73865 100644
--- a/setup.py
+++ b/setup.py
@@ -60,6 +60,7 @@ Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
Programming Language :: Python :: 3.10
+Programming Language :: Python :: 3.11
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: Implementation :: CPython
Programming Language :: C