summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <piro@gambitresearch.com>2017-03-02 17:28:01 +0000
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2017-03-11 17:31:37 +0000
commit2aece82c21e7a652901027c136ef58ac6b1a28d3 (patch)
tree697168757cfa5d1f4f02312e08c64bae68743066
parent09c48c76c3b91139c9d645834962c75433281cb9 (diff)
downloadpsycopg2-test_libpq91.tar.gz
Build psycopg using libpq 9.1test_libpq91
Building with 9.2 reported failing on CentOS 7 in issue #520. I would leave this commit in a branch aside for the moment, because this is useful but it cannot replace building with more modern libpq, because some features are not compiled in and some tests skipped.
-rw-r--r--.travis.yml4
1 files changed, 3 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 4d558f1..050e9a7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -14,7 +14,9 @@ python:
- 3.2
install:
- - python setup.py install
+ - wget -O - http://initd.org/psycopg/upload/postgresql/postgresql-9.1.tar.bz2
+ | sudo tar xjf - -C /usr/lib/postgresql
+ - python setup.py build_ext --pg-config=/usr/lib/postgresql/9.1/bin/pg_config install
- sudo scripts/travis_prepare.sh
script: