summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7bbb0693..27bba266 100644
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,7 @@ PY3_DEPS = \
flake8-quotes \
isort \
pep8-naming \
+ pylint \
pyperf \
pypinfo \
requests \
@@ -197,6 +198,9 @@ flake8: ## Run flake8 linter.
isort: ## Run isort linter.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --check-only --jobs=${NUM_WORKERS}
+pylint: ## Python pylint (not mandatory, just run it from time to time)
+ @git ls-files '*.py' | xargs $(PYTHON) -m pylint --rcfile=pyproject.toml --jobs=${NUM_WORKERS}
+
c-linter: ## Run C linter.
@git ls-files '*.c' '*.h' | xargs $(PYTHON) scripts/internal/clinter.py