summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 5088cb72..c27db46d 100644
--- a/Makefile
+++ b/Makefile
@@ -121,7 +121,7 @@ setup-dev-env: ## Install GIT hooks, pip, test deps (also upgrades them).
# Tests
# ===================================================================
-test: ## Run all tests.
+test: ## Run all tests. To run a specific test do "make test ARGS=psutil.tests.test_system.TestDiskAPIs"
${MAKE} build
$(TEST_PREFIX) $(PYTHON) $(TSCRIPT) $(ARGS)
@@ -169,10 +169,6 @@ test-memleaks: ## Memory leak tests.
${MAKE} build
$(TEST_PREFIX) $(PYTHON) $(TSCRIPT) $(ARGS) psutil/tests/test_memleaks.py
-test-by-name: ## e.g. make test-by-name ARGS=psutil.tests.test_system.TestSystemAPIs
- ${MAKE} build
- $(TEST_PREFIX) $(PYTHON) $(TSCRIPT) $(ARGS)
-
test-failed: ## Re-run tests which failed on last run
${MAKE} build
$(TEST_PREFIX) $(PYTHON) $(TSCRIPT) $(ARGS) --last-failed