summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-02-20 16:24:43 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-02-20 16:24:43 +0100
commiteb5ce8033263aafe37c35a875c5bb57c8f538353 (patch)
tree78eefc0bc45bfcb85e252278275165fe870e16ae
parentd77f3003386888cca291233ab940c4db33a1f86b (diff)
downloadpsutil-print-leftover.tar.gz
refactor CI scriptsprint-leftover
-rwxr-xr-x.ci/travis/run.sh16
-rw-r--r--.cirrus.yml8
2 files changed, 12 insertions, 12 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 879e78a6..9cb6cfe1 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -13,26 +13,26 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
pyenv activate psutil
fi
-# install psutil
-make clean
-python setup.py build
-python setup.py develop
+make install
+
+echo "Testing on Python $PYVER"
+$PYTHON -m pip freeze
# run tests (with coverage)
if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
PSUTIL_TESTING=1 python -Wa -m coverage run psutil/tests/runner.py
else
- PSUTIL_TESTING=1 python -Wa psutil/tests/runner.py
+ make test PYTHON=python
fi
if [ "$PYVER" == "2.7" ] || [ "$PYVER" == "3.6" ]; then
# run mem leaks test
- PSUTIL_TESTING=1 python -Wa psutil/tests/test_memory_leaks.py
+ make test-memleaks PYTHON=python
# run linter (on Linux only)
if [[ "$(uname -s)" != 'Darwin' ]]; then
make lint PYTHON=python
fi
fi
-PSUTIL_TESTING=1 python -Wa scripts/internal/print_access_denied.py
-PSUTIL_TESTING=1 python -Wa scripts/internal/print_api_speed.py
+make print-access-denied PYTHON=python
+make print-api-speed PYTHON=python
diff --git a/.cirrus.yml b/.cirrus.yml
index d06867fb..a0b8f1f0 100644
--- a/.cirrus.yml
+++ b/.cirrus.yml
@@ -11,8 +11,8 @@ freebsd_13_py3_task:
- make install
- make test
- make test-memleaks
- - PSUTIL_TESTING=1 python3 -Wa scripts/internal/print_access_denied.py
- - PSUTIL_TESTING=1 python3 -Wa scripts/internal/print_api_speed.py
+ - make print-access-denied
+ - make print-api-speed
freebsd_11_py2_task:
freebsd_instance:
@@ -27,5 +27,5 @@ freebsd_11_py2_task:
- make install
- make test
- make test-memleaks
- - PSUTIL_TESTING=1 python3 -Wa scripts/internal/print_access_denied.py
- - PSUTIL_TESTING=1 python3 -Wa scripts/internal/print_api_speed.py
+ - make print-access-denied
+ - make print-api-speed