summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-04-30 03:23:55 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2020-04-30 03:23:55 +0200
commitdd00e0dcd6612cf31fad6f13b8245483be67225f (patch)
treea40465f32b52699a5996583556cf8afdd2a4910f
parent4b9e3049bf9f4f908e2bd42b8c4fa8b222bec1f4 (diff)
downloadpsutil-parallel-build.tar.gz
reconfig travisparallel-build
-rwxr-xr-x.ci/travis/run.sh15
1 files changed, 5 insertions, 10 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 562564b0..821e05f7 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -13,26 +13,21 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
pyenv activate psutil
fi
-# install psutil
-make clean
-python setup.py build
-python setup.py develop
-
# run tests (with coverage)
if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
- PSUTIL_TESTING=1 python -Wa -m coverage run psutil/tests/runner.py
+ make test PYTHON=python
else
- PSUTIL_TESTING=1 python -Wa psutil/tests/runner.py --parallel
+ make test-parallel PYTHON=python
fi
if [ "$PYVER" == "2.7" ] || [ "$PYVER" == "3.6" ]; then
# run mem leaks test
- PSUTIL_TESTING=1 python -Wa psutil/tests/test_memory_leaks.py
+ make test-memleaks PYTHON=python
# run linter (on Linux only)
if [[ "$(uname -s)" != 'Darwin' ]]; then
make lint PYTHON=python
fi
fi
-PSUTIL_TESTING=1 python -Wa scripts/internal/print_access_denied.py
-PSUTIL_TESTING=1 python -Wa scripts/internal/print_api_speed.py
+make print-access-denied PYTHON=python
+make print-api-speed PYTHON=python