summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
Diffstat (limited to 'README')
-rw-r--r--README20
1 files changed, 20 insertions, 0 deletions
diff --git a/README b/README
new file mode 100644
index 0000000..93b93de
--- /dev/null
+++ b/README
@@ -0,0 +1,20 @@
+posix_ipc is a Python module (written in C) that permits creation and
+manipulation of POSIX inter-process semaphores, shared memory and message
+queues on platforms supporting the POSIX Realtime Extensions a.k.a. POSIX
+1003.1b-1993. This includes nearly all Unices and Windows + Cygwin 1.7.
+
+posix_ipc is compatible with Python 2 and 3.
+
+The latest version, contact info, sample code, etc. are available on PyPI
+and here:
+http://semanchuk.com/philip/posix_ipc/
+
+Installation is as simple as `python setup.py install`. Usage, a version
+history, warnings, suggestions, etc. are covered in ReadMe.html.
+
+posix_ipc is free software (free as in speech and free as in beer) released
+under a 3-clause BSD license. Complete licensing information is available in
+the LICENSE file.
+
+You might also be interested in the similar System V IPC module at:
+http://semanchuk.com/philip/sysv_ipc/