summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer McIntyre <zeroSteiner@gmail.com>2020-09-11 20:43:55 -0400
committerSpencer McIntyre <zeroSteiner@gmail.com>2021-05-16 12:12:48 -0400
commit2a5db4c0bba11dc6dff0110c298e3ab9d8521532 (patch)
tree27b99f002b35d22afa52d2db3410be57c114c007
parentf5066257b30f8445a4e65519fb999dc99c3b57d4 (diff)
downloadpluginbase-master.tar.gz
Add a Pipfile with pytest and some scriptsHEADv1.0.1master
-rw-r--r--.gitignore1
-rw-r--r--Pipfile14
2 files changed, 15 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index 60b1420..5b6977e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
dist
build
docs/_build
+Pipfile.lock
diff --git a/Pipfile b/Pipfile
new file mode 100644
index 0000000..49489b5
--- /dev/null
+++ b/Pipfile
@@ -0,0 +1,14 @@
+[[source]]
+name = "pypi"
+url = "https://pypi.org/simple"
+verify_ssl = true
+
+[packages]
+
+[dev-packages]
+pytest = "*"
+
+[scripts]
+release = 'sh -c "python setup.py build sdist && twine upload --verbose dist/*"'
+tests = 'sh -c "cd tests; PYTHONPATH=.. py.test --tb=native"'
+