summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJules Chéron <jules.cheron@gmail.com>2022-11-10 14:15:58 +0100
committerJules Chéron <jules.cheron@gmail.com>2022-11-10 14:15:58 +0100
commitb1f4bfb7a9accd37cea3d8d8c53c184db4dfb7e8 (patch)
treeeb496223badbda3e3bdddb830da0d9dec69be570 /pyproject.toml
parent0200f9f18a211dd9a3ea735e802a670cf1a19ed3 (diff)
downloadpint-b1f4bfb7a9accd37cea3d8d8c53c184db4dfb7e8.tar.gz
draft PEP621
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml68
1 files changed, 67 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 771af68..83f4fd1 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,71 @@
[build-system]
-requires = ["setuptools>=41", "wheel", "setuptools_scm[toml]>=3.4.3"]
+requires = ["setuptools>=61", "wheel", "setuptools_scm[toml]>=3.4.3"]
build-backend = "setuptools.build_meta"
[tool.setuptools_scm]
+
+[project]
+name = "Pint"
+authors = [
+ {name="Hernan E. Grecco", email="hernan.grecco@gmail.com"}
+]
+license = {text = "BSD"}
+description = "Physical quantities module"
+readme = "README.rst"
+maintainers = [
+ {name="Hernan E. Grecco", email="hernan.grecco@gmail.com"},
+ {name="Jules Chéron", email="julescheron@gmail.com"}
+]
+keywords = ["physical", "quantities", "unit", "conversion", "science"]
+classifiers = [
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "Intended Audience :: Science/Research",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: MacOS :: MacOS X",
+ "Operating System :: Microsoft :: Windows",
+ "Operating System :: POSIX",
+ "Programming Language :: Python",
+ "Topic :: Scientific/Engineering",
+ "Topic :: Software Development :: Libraries",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11"
+]
+requires-python = ">=3.8"
+dynamic = ["version"]
+
+[project.optional-dependencies]
+test = [
+ "pytest",
+ "pytest-mpl",
+ "pytest-cov",
+ "pytest-subtests"
+]
+numpy = ["numpy >= 1.19.5"]
+uncertainties = ["uncertainties >= 3.1.6"]
+babel = ["babel <= 2.8"]
+pandas = ["pint-pandas >= 0.3"]
+xarray = ["xarray"]
+dask = ["dask"]
+
+[project.urls]
+Homepage = "https://github.com/hgrecco/pint"
+Documentation = "https://pint.readthedocs.io/"
+
+[project.scripts]
+pint-convert = "pint.pint_convert:main"
+
+[tool.setuptools]
+packages = ["pint"]
+
+[tool.isort]
+profile = "black"
+default_section="THIRDPARTY"
+known_first_party="pint"
+multi_line_output=3
+include_trailing_comma=true
+force_grid_wrap=0
+use_parentheses=true
+line_length=88