summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorHernan <hernan.grecco@gmail.com>2023-04-24 20:45:12 -0300
committerHernan <hernan.grecco@gmail.com>2023-04-24 21:15:33 -0300
commit276164cd399fe1a1437c5717abf54e39186d68b3 (patch)
treec6b7372f1c60cf0add1110304c47ac9775d95387 /pyproject.toml
parent589a51bcb0d2ec7f5e2cd48995f88a030eb53efb (diff)
downloadpint-276164cd399fe1a1437c5717abf54e39186d68b3.tar.gz
Migrate isort and flake8 settings to ruff
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml28
1 files changed, 19 insertions, 9 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b173afb..00d06be 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -67,12 +67,22 @@ build-backend = "setuptools.build_meta"
[tool.setuptools_scm]
-[tool.isort]
-profile = "black"
-default_section="THIRDPARTY"
-known_first_party="pint"
-multi_line_output=3
-include_trailing_comma=true
-force_grid_wrap=0
-use_parentheses=true
-line_length=88
+[tool.ruff.isort]
+required-imports = ["from __future__ import annotations"]
+known-first-party= ["pint"]
+
+
+[tool.ruff]
+ignore = [
+ # whitespace before ':' - doesn't work well with black
+ # "E203",
+ "E402",
+ # line too long - let black worry about that
+ "E501",
+ # do not assign a lambda expression, use a def
+ "E731",
+ # line break before binary operator
+ # "W503"
+]
+extend-exclude = ["build"]
+line-length=88