summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorClark Willison <clarkgwillison@gmail.com>2020-07-13 21:07:11 -0700
committerClark Willison <clarkgwillison@gmail.com>2020-07-13 21:07:11 -0700
commit76007cf57d468c5bf664857412939d559ecefbde (patch)
tree118c1039d13014e8f972b71af34c3654e2569dc6 /docs
parent6670f1122539970fce0c37b7db21f04e703a7a02 (diff)
downloadpint-76007cf57d468c5bf664857412939d559ecefbde.tar.gz
install docs: remove references to (removed) AUR package
Diffstat (limited to 'docs')
-rw-r--r--docs/getting.rst24
1 files changed, 7 insertions, 17 deletions
diff --git a/docs/getting.rst b/docs/getting.rst
index 09815fe..84239e2 100644
--- a/docs/getting.rst
+++ b/docs/getting.rst
@@ -9,13 +9,19 @@ You can install it (or upgrade to the latest version) using pip_::
$ pip install -U pint
-That's all! You can check that Pint is correctly installed by starting up python, and importing pint:
+That's all! You can check that Pint is correctly installed by starting up python, and importing Pint:
.. code-block:: python
>>> import pint
>>> pint.__version__ # doctest: +SKIP
+Or running the test suite:
+
+.. code-block:: python
+
+ >>> pint.test()
+
.. note:: If you have an old system installation of Python and you don't want to
mess with it, you can try `Anaconda CE`_. It is a free Python distribution by
Continuum Analytics that includes many scientific packages. To install pint
@@ -23,18 +29,6 @@ That's all! You can check that Pint is correctly installed by starting up python
$ conda install -c conda-forge pint
-You can check the installation with the following command:
-
-.. code-block:: python
-
- >>> pint.test() # doctest: +SKIP
-
-
-On Arch Linux, you can alternatively install Pint from the Arch User Repository
-(AUR). The latest release is available as `python-pint`_, and packages tracking
-the master branch of the GitHub repository are available as `python-pint-git`_
-and `python2-pint-git`_.
-
Getting the code
----------------
@@ -56,13 +50,9 @@ Once you have a copy of the source, you can embed it in your Python package, or
$ python setup.py install
-
.. _easy_install: http://pypi.python.org/pypi/setuptools
.. _Python: http://www.python.org/
.. _pip: http://www.pip-installer.org/
.. _`Anaconda CE`: https://store.continuum.io/cshop/anaconda
-.. _`python-pint`: https://aur.archlinux.org/packages/python-pint/
-.. _`python-pint-git`: https://aur.archlinux.org/packages/python-pint-git/
-.. _`python2-pint-git`: https://aur.archlinux.org/packages/python2-pint-git/
.. _PyPI: https://pypi.python.org/pypi/Pint/
.. _GitHub: https://github.com/hgrecco/pint